Help Center/ MapReduce Service/ User Guide/ MRS Manager Operation Guide (Applicable to 2.x and Earlier Versions)/ Alarm Reference (Applicable to MRS 2.x and Earlier Versions)/ ALM-26052 Number of Available Supervisors in Storm Is Lower Than the Threshold (For MRS 2.x or Earlier)
Updated on 2024-04-11 GMT+08:00

ALM-26052 Number of Available Supervisors in Storm Is Lower Than the Threshold (For MRS 2.x or Earlier)

Description

The system checks the number of supervisors every 60 seconds and compares it with the threshold. This alarm is generated if the number of supervisors is lower than the threshold.

To modify the threshold, users can choose System > Threshold Configuration on MRS Manager.

This alarm is cleared if the number of supervisors is greater than or equal to the threshold.

Attribute

Alarm ID

Alarm Severity

Auto Clear

26052

Major

Yes

Parameters

Parameter

Description

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Trigger Condition

Generates an alarm when the actual indicator value exceeds the specified threshold.

Impact on the System

  • Existing tasks in the cluster cannot be executed.
  • The cluster can receive new Storm tasks but cannot execute them.

Possible Causes

Supervisors are abnormal in the cluster.

Procedure

  1. Check the supervisor status.

    1. Go to the cluster details page and click Components.
    2. Choose Storm > Supervisor.
    3. In Role, check whether the cluster has supervisor instances that are in the Faulty or Recovering state.
      • If yes, go to 1.d.
      • If no, go to 2.
    4. Select the supervisor instances that are in the Faulty or Recovering state and choose More > Restart Instance.
      • If yes, go to 1.e.
      • If the restart fails, go to 2.
    5. Wait 30 seconds and check whether the alarm is cleared.
      • If yes, no further action is required.
      • If no, go to 2.

  2. Collect fault information.

    1. On MRS Manager, choose System > Export Log.
    2. Contact the O&M engineers and send the collected logs.

Related Information

N/A