ALM-24000 Flume Service Unavailable (For MRS 2.x or Earlier)
Description
The alarm module checks the Flume service status every 180 seconds. This alarm is generated if the Flume service is abnormal.
This alarm is cleared after the Flume service recovers.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
24000 |
Critical |
Yes |
Parameters
Parameter |
Description |
---|---|
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
Flume cannot work and data transmission is interrupted.
Possible Causes
- HDFS is unavailable.
- LdapServer is unavailable.
Procedure
- Check the HDFS status.
- Go to the MRS cluster details page and choose Alarms.
- Check whether the ALM-14000 HDFS Service Unavailable alarm is generated.
- If yes, clear the alarm according to the handling suggestions of "ALM-14000 HDFS Service Unavailable".
- If no, go to 2.
- Check the LdapServer status.
Check whether the ALM-25000 LdapServer Service Unavailable alarm is generated.
- If yes, clear the alarm according to the handling suggestions of "ALM-25000 LdapServer Service Unavailable".
- If no, go to 3.b.
- Check whether the HDFS and LdapServer services are stopped.
- Go to the MRS cluster details page and click Components.
- In the service list on MRS Manager, check whether the HDFS and LdapServer services are stopped.
- Check whether the "ALM-24000 Flume Service Unavailable" alarm is cleared.
- If yes, no further action is required.
- If no, go to 4.
- Collect fault information.
- On MRS Manager, choose .
- Contact the O&M engineers and send the collected logs.
Related Information
N/A
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