ALM-12004 OLdap Resource Abnormal (For MRS 2.x or Earlier)
Description
This alarm is generated when the Ldap resource in Manager is abnormal.
This alarm is cleared when the Ldap resource in Manager recovers and the alarm handling is complete.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
12004 |
Major |
Yes |
Parameter
Parameter |
Description |
---|---|
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
The Manager authentication services are unavailable and cannot provide security authentication and user management functions for web upper-layer services. Users may be unable to log in to Manager.
Possible Causes
The LdapServer process in Manager is abnormal.
Procedure
- Check whether the LdapServer process in Manager is normal.
- Log in to the active management node.
- Run ps -ef | grep slapd to check whether the LdapServer resource process in the ${BIGDATA_HOME}/om-0.0.1/ directory of the configuration file is running properly.
You can determine that the resource is normal as follows:
- Run sh ${BIGDATA_HOME}/om-0.0.1/sbin/status-oms.sh and find that ResHAStatus of the OLdap process is Normal.
- Run ps -ef | grep slapd and find that the slapd process occupies port 21750.
- Run kill -2 PID of the LdapServer process and wait 20 seconds. The HA starts the OLdap process automatically. Check whether the status of the OLdap resource is normal.
- If yes, no further action is required.
- If no, go to 3.
- Collect fault information.
- On MRS Manager, choose .
- Contact the O&M engineers and send the collected logs.
Reference
None
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