Updated on 2023-09-05 GMT+08:00

Error 500 Is Reported When a User Accesses the Component Web UI

Issue

Error 500 is reported when a user accesses the component web UI.

Symptom

Error 500 is reported when a user accesses the component web UI. The detailed error information is as follows:

HTTP ERROR 500 java.io.IOException: Service connectivity error.

Possible Causes

The possible cause is that the number of Knox threads is insufficient.

Procedure

  1. Log in to active and standby OMS nodes as user root, respectively.
  2. Add the following configuration to the gateway-site.xml file on the active and standby OMS nodes to increase the number of thread pools:

    vi /opt/knox/conf/gateway-site.xml

    <property>
    <name>gateway.httpclient.maxConnections</name>
    <value>64</value>
    </property>

  3. Log in to the active OMS node as user omm and run the following command to restart the Knox process:

    sh /opt/knox/bin/restart-knox.sh

  4. Wait for 5 minutes and check whether the component web UI can be accessed.

    • If yes, no further action is required.
    • If no, contact O&M personnel.