Error 500 Is Reported When a User Accesses the Component Web UI
Issue
Error 500 is reported when a user accesses the component web UI.
Symptom
Error 500 is reported when a user accesses the component web UI. The detailed error information is as follows:
HTTP ERROR 500 java.io.IOException: Service connectivity error.
Possible Causes
The possible cause is that the number of Knox threads is insufficient.
Procedure
- Log in to active and standby OMS nodes as user root, respectively.
- Add the following configuration to the gateway-site.xml file on the active and standby OMS nodes to increase the number of thread pools:
vi /opt/knox/conf/gateway-site.xml
<property> <name>gateway.httpclient.maxConnections</name> <value>64</value> </property>
- Log in to the active OMS node as user omm and run the following command to restart the Knox process:
sh /opt/knox/bin/restart-knox.sh
- Wait for 5 minutes and check whether the component web UI can be accessed.
- If yes, no further action is required.
- If no, contact O&M personnel.
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