Updated on 2023-09-05 GMT+08:00

Why Does the Manager Page Freeze?

Question

The Manager page of MRS clusters responds slowly.

Symptom

After a user logs in to Manager of an MRS cluster and clicks a button, data can be loaded only one minute later. After some buttons are clicked, frame freezing occurs and the pages cannot be accessed.

Possible Causes

View the /var/log/Bigdata/omm/oms/pms/scriptlog/pms_script.log file. The content of the /var/log/Bigdata/omm/oms/pms/pms.log file is similar to the following:

According to the logs, memory overflow occurs. Therefore, it can be determined that the Manager page freezes due to insufficient PMS memory.

Procedure

  1. Log in to the active management node as user omm.
  2. Run the following command to open the application.properties file:

    vi ${BIGDATA_HOME}/om-server_*/OMS/workspace0/conf/pms/application.properties

  3. Increase the value of pms.mem for the PMS process based on site requirements, save the modification, and exit.

    ...
    pms.mem=800m

    The increment of the new value cannot be greater than the free memory of the OS.

  4. Run the following commands to query the PID of the PMS process, stop the PMS process, and wait for the process to restart:

    ps -ef | grep pms

    kill -9 PID

  5. Log in to Manager and check whether frame freezing disappears.