Help Center> ModelArts> Troubleshooting> Inference Deployment> Service Deployment> What Do I Do If a Container Health Check Fails When a Service Is Deployed, Started, Upgraded, or Modified?
Updated on 2024-06-11 GMT+08:00

What Do I Do If a Container Health Check Fails When a Service Is Deployed, Started, Upgraded, or Modified?

Possible Causes

Calling the container health check API failed. The possible causes are as follows:

  • The health check is incorrectly configured for the image.
  • The health check is incorrectly configured for the AI application.

Solution

Check container logs for the cause of the health check failure.

  • If the health check is incorrectly configured for the image, debug the code, create an image again and then the AI application, and use the new AI application to deploy the service. For details about how to configure the image health API for an image, see parameter health in Specifications for Writing the Model Configuration File.
  • If the health check is incorrectly configured for the AI application, create a new AI application or create a version of the existing AI application, correctly configure the health check, and use the new AI application or version to deploy the service. For details about the AI application health check, see parameter Health Check in Creating and Importing a Model Image.