Help Center/ ModelArts/ Tool Guide (Cloud Alliance scenario)/ FAQs/ An Error Occurs When You Edit a Credential in PyCharm Toolkit
Updated on 2023-06-30 GMT+08:00

An Error Occurs When You Edit a Credential in PyCharm Toolkit

Symptom

When you edit a credential in PyCharm Toolkit, the message "Validate Credential error" is displayed.

Or

Possible Causes

  • Possible cause 1: Information such as the region is incorrectly configured.
  • Possible cause 2: The hosts file is not configured or is incorrectly configured.
  • Possible cause 3: The network proxy settings are incorrect.
  • Possible cause 4: The AK/SK is incorrect.
  • Possible cause 5: The computer time is incorrectly set.

Solution

1. Information such as the region is incorrectly configured.

Configure the correct information.

For example, if the endpoint is incorrect, the authentication fails.

Incorrect example: The endpoint is preceded by https.

Figure 1 Configuring PyCharm Toolkit

2. The hosts file is not configured or is incorrectly configured.

Configure the domain names and IP addresses in the hosts file on the local PC.

Network proxy settings are incorrect.

If the network requires proxy settings, check whether the proxy settings are correct. You can also use the mobile hotspot to test.

Check whether the proxy settings are correct.

Figure 2 PyCharm network proxy settings

4. The AK/SK is incorrect.

The obtained AK/SK is incorrect. Obtain the correct AK/SK and try again. For details, see Creating Access Keys (AK and SK).

If you use a RightCloud account, contact the technical support of the region to obtain the AK/SK.

5. The computer time is incorrectly set.

Set the computer time to the correct time.