Help Center> Server Migration Service> FAQs> Disk Management> How Do I Detach the Temporary System Disk from My Target Server and Re-attach the Original Disk?
Updated on 2024-05-15 GMT+08:00

How Do I Detach the Temporary System Disk from My Target Server and Re-attach the Original Disk?

The solution described here works for ECSs except spot ECSs. It does not work for HECSs. Spot ECSs and HECSs do not allow you to detach or attach disks. If your target server is a spot ECS or HECS, contact technical support.

Symptom

After you deleted a failed or suspended migration task from the SMS console, the target server was still using the temporary system disk, whose name starts with SMS. As a result, the original system disk could not be re-attached.

Possible Causes

If a migration task fails or is suspended, the system will not automatically detach the temporary system disk and re-attach the original system disk. If you want to restore this server to its original condition, you need to perform this step manually.

Solution

  1. Detach the temporary system disk.

    1. Log in to the ECS console.
    2. In the server list, locate this server and click its name.
    3. Click the Disks tab, locate disk SMS-Temp_Disk_Deleted-after-migration, and click Detach.

    4. Click Yes.

  2. Detach the original system disk.

    The original system disk is attached as a data disk. You need to detach it and attach it as a system disk again.

    1. Detach the original system disk from the target server by referring to step 1.

    2. Log in to the EVS console. In the disk list, locate the disk you detached and click the disk name.

      Check whether the disk has changed from a data disk to a system disk. If it has, go to the next step.

  3. Reattach the original system disk.

    Reattach the disk you detached in step 3 as a system disk to the target server. For details, see Calling APIs.

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