How Do I Fix Error "Failed to start sms agent! disks" When I Start the Agent on a Linux Source Server?
Symptom
When you started the Agent on a Linux source server, message "Failed to start sms agent! disks" was displayed.
Possible Causes
Possible causes are:
- There are multiple volume groups with the same name.
Check whether the SmsAgent_Error.log file records "Multiple VGs found with the same name".
SMS requires that a Linux source server cannot have volume groups with the same name, or the Agent will be unable to collect information about the source server disks. Run the vgdisplay command to check whether there are volume groups with the same name, and run the lvdisplay command to view logical volume properties, such as the host name and creation time.
- The fdisk command cannot be found on the source server.
Run the fdisk -l command on the source server to check whether the fdisk command exists in your path. If fdisk cannot be found, the possible cause is that the /sbin directory is not included in PATH, or the /sbin directory is included in PATH but does not take effect. This problem may occur after you run the su command to switch to the root user.
Solutions
- If there are volume groups with the same name in Linux, these volume groups and the corresponding logical volumes cannot be mounted or read.
You can detach the involved disks from the source server and attach them to another server. Then check whether the data on the disks needs to be migrated.
- If the data needs to be migrated, run the vgrename command to rename each of these volume groups, and attach the disks back to the source server. Then restart the SMS Agent.
- If the data does not need to be migrated, restart the SMS Agent. After the migration is complete, attach the disks back to the source server.
- Run the source /etc/profile command and restart the SMS Agent.
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