Help Center/ Server Migration Service/ FAQs/ Known Errors and Solutions/ SMS.0203 Connection from Source Server to API Gateway Timed Out
Updated on 2024-08-22 GMT+08:00

SMS.0203 Connection from Source Server to API Gateway Timed Out

Symptom

When you started the Agent, the error "SMS.0203 Connection from source server to API Gateway timed out" was reported.

Possible Causes

The source server does not have Internet access and cannot communicate with SMS, IAM, ECS, EVS, IMS, VPC, or EPS. In this case, check the source network.

Solution

  1. Log in to the source server.
  2. Confirm that you can access IAM and SMS from the source server.

    curl -v https://iam.myhuaweicloud.com:443

    Check whether the source server can access ECS, EVS, IMS, and VPC using the commands for the region you are migrating to.

    Command

    Remarks

    • curl -v https://ecs.{regionCode}.myhuaweicloud.com:443
    • curl -v https://evs.{regionCode}.myhuaweicloud.com:443
    • curl -v https://ims.{regionCode}.myhuaweicloud.com:443
    • curl -v https://vpc.{regionCode}.myhuaweicloud.com:443

    Replace {Region code} with the ID of the region you are migrating to . For details, see Obtaining Region Information.

    If the source server runs Windows and curl is not available on it, you can also use a browser to access the preceding domain names. If the information shown in the following figure is displayed, the access is successful.

  3. Check if the curl operation is successful. If it is, the information shown in the following figure is returned, and the source server can access the domain name of the cloud service. Restart the Agent on the source server.

    If the curl operation fails, for example, the operation timed out, check the network and firewall configurations of the source server and rectify network issues if any. Then confirm the source server can access the preceding domain names.