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- What's New
- Function Overview
- Service Overview
- Getting Started
- User Guide
-
Best Practices
- Overview
- Automatically Checking for and Retrying Failed Migration Tasks
- Cutover Migration
- Special Migration Scenarios
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Migration from Other Clouds to Huawei Cloud
- Migrating Data Between Huawei Cloud OBS Buckets
- Migrating Data from Huawei Cloud PFS to Huawei Cloud OBS or Between PFS Systems
- Migrating Data from Alibaba Cloud OSS to Huawei Cloud OBS
- Migrating Data from Tencent Cloud COS to Huawei Cloud OBS
- Migrating Data from UCloud US3 to Huawei Cloud OBS
- Migrating Data from Kingsoft Cloud KS3 to Huawei Cloud OBS
- Migrating Data from QingCloud QingStor to Huawei Cloud OBS
- Migrating Data from Google Cloud Storage to Huawei Cloud OBS
- Migrating Data from Amazon S3 to Huawei Cloud OBS
- Migrating Data from Azure Blob Storage to Huawei Cloud OBS
- Migrating Data from HTTP/HTTPS Sources to Huawei Cloud OBS
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Archive Data Migration
- Migrating Archived Data in Huawei Cloud OBS
- Migrating Archived Data in Alibaba Cloud OSS
- Migrating Archived Data in Tencent Cloud COS
- Migrating Archived Data in Kingsoft Cloud KS3
- Migrating Archived Data in UCloud US3
- Migrating Archived Data in Amazon S3
- Migrating Archived Data in Azure Blob Storage
- API Reference
-
FAQs
- Question Summary
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Product Consulting
- When Do I Need to Perform Pre-migration Evaluation Before Creating Migration Tasks?
- How Do I Migrate OBS Bucket Data from One Region to Another?
- How Do I Migrate the OBS Bucket Data from One Account to Another?
- How Do I Migrate Data from Multiple Source Buckets to a Single OBS Bucket on Huawei Cloud?
- How Do I Migrate Data in the Root Directory?
- How Does Migration Affect My Source Data? What Are the Impacts on Migration If the Source Data Changes?
- How Do I Change the Storage Path of a Migrated Object?
- How Do I Migrate Incremental Source Data and How Does OMS Ensure Data Consistency?
- How Do I Obtain Required Permissions for the Source and Destination Platform Accounts?
- How Do I Review the Objects Migrated in a Migration Task?
- How Do I Review the Objects Migrated in a Migration Task Group?
- Can OMS Only Migrate the Data Generated After a Specified Time?
- Can OMS Filter the Data to Be Migrated by Suffix?
- What Is the Storage Class of Archive Data Migrated to the Archive Destination Bucket?
- What Are the Application Scenarios of Migration Tasks and Migration Task Groups?
- How Does OMS Ensure Data Consistency Between the Source and Destination Buckets?
- Why Is the Total Number or Size of Objects in the Destination Bucket Inconsistent with Those in the Source Bucket After the Migration?
- How Does the Migration Affect Data in the Destination Bucket?
- Why Are the Migration Progress and the Transmitted Data Volume 0 After the Migration Is Complete?
- How Do I Choose Storage Classes?
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Migration Constraints
- What Are the Constraints on Migrating Data to a Parallel File System with OMS?
- What Are the Restrictions on Migrating Data in a Parallel File System?
- How Do I Fix the Error "Destination bucket must be in the same region as OMS. Select a bucket that is located in region xxx, or change the OMS region to xxx" When I Create a Migration Task?
- Migration Duration
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Exception Recovery
- What Can I Do If Migration Tasks Fail To Be Created After Evaluation?
- What Can I Do If the Migration Fails Because the Frequency of Accessing the Source Object Storage Exceeded the Upper Limit?
- What Can I Do If a Migration Task Fails?
- What Can I Do If a Migration Task Group Fails to Be Executed?
- What Do I Do If SMN Does Not Work Properly?
- What Do I Do If a Migration Task Fails Due to an Inconsistent Encryption Attribute?
- What Can I Do If the Migration Task Failed Due to an Archive Data Read Failure?
- What Problems May I Encounter If CDN Is Enabled at the Source?
- What Do I Do If All Objects Whose Names Contain Slashes (/) Fail to be Migrated from Alibaba Cloud?
- How Do I Resolve the Error "Failed to access the object. Make sure that the object exists and you have the rights to access" When I Enter Object Prefixes?
- What Can I Do If Consistency Checks Fail During the Migration of Data in a Parallel File System?
- What Can I Do If the Migration Failed Because the Objects Cannot Be Downloaded from the Source Bucket?
- What Can I Do If a Migration Task Failed Due to Transmission Interruptions?
What Problems May I Encounter If CDN Is Enabled at the Source?
Problem 1
The CDN domain name configuration fails the check before the migration, and the error code COMPARE_SRC_AND_CDN_FAILURE is returned.
Possible Causes
The object metadata obtained by OMS from the source bucket does not match the HTTP header in the response from CDN. To be specific, the object size is inconsistent or the last modification time of the cached object on CDN is earlier.
Solution
- Check whether the CDN domain name can be used to download the object from the CDN. OMS uses the URL consisting of the CDN domain name and the object name to download the object.
- If the URL cannot be accessed, check whether anti-leeching is enabled for CDN.
- If the URL can be accessed, go to 22.
- Check whether the values of Content-Length and Last-Modified in the HTTP response header are the same as those in the object metadata obtained from the source bucket.
- If the Content-Length value is inconsistent with that in the metadata, check whether image compression is enabled on CDN. If yes, disable image compression and perform the migration again.
Figure 1 Object size in the metadataFigure 2 Compressed object size
- If the Last-Modified value is earlier than that in the metadata, refresh the CDN cache and perform the migration again.
- If the Content-Length value is inconsistent with that in the metadata, check whether image compression is enabled on CDN. If yes, disable image compression and perform the migration again.
Problem 2
The migration fails and the error code COMPARE_SRC_AND_CDN_FAILURE is displayed in the list of failed objects.
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Possible Causes
Before the migration, OMS detects that the size and the last modification time of the object obtained from the source bucket are inconsistent with those obtained from CDN.
If the source object is updated, but the CDN cache is not, this error will be reported.
Solution
Update the CDN cache so that the cached object on CDN is the latest.
Problem 3
The migration fails and the error code 403 is displayed in the list of failed objects.
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Possible Causes
403 indicates that OMS does not have the permissions to access the CDN domain name because:
- The CDN is public, and anti-leeching was enabled for it.
- The CDN is private, and CND authentication was not enabled for the migration task or task group.
Solutions
- Disable anti-leeching. If anti-leeching cannot be disabled for security purposes, contact Huawei Cloud technical support.
- Enable CND authentication and correctly enter the CDN verification key on when you configure a migration task or task group the OMS console.
Problem 4
The migration fails and the error code COMPARE_SRC_AND_CDN_FAILURE is displayed in the list of failed objects.
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Possible Causes
CDN performance optimization, such as Gzip compression or page optimization, is enabled at the source. OMS has learned how large the object is based on Content-Length of the object metadata obtained from the source bucket. However, when transmitting this object, OMS finds that the object is compressed and its size is smaller than what OMS has learned. OkHttp3 determines that the stream is interrupted during data transmission. As a result, the migration fails.
Solutions
- Solution 1: Disable CDN performance optimization and then perform the migration again.
- Solution 2: Use the URL list method to perform the migration. When configuring the advanced options, set Consistency Check to Not required.
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