Updated on 2024-04-11 GMT+08:00

ALM-45325 Presto Service Unavailable (For MRS 2.x or Earlier)

Description

The system checks the Presto service status every 60 seconds. This alarm is generated when the system detects that Presto is unavailable.

This alarm is cleared when the Presto service recovers.

Attribute

Alarm ID

Alarm Severity

Auto Clear

45325

Critical

Yes

Parameters

Name

Meaning

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

Presto cannot run SQL queries.

Possible Causes

  • The Presto coordinator or worker process is faulty.
  • The network communication between Presto coordinator and worker instances is interrupted.

Procedure

  1. Check the status of the coordinator and worker processes.

    1. Log in to FusionInsight Manager and choose Cluster > Services > Presto. On the page that is displayed, click the Instance tab. In the Presto instance list, check whether the status of all coordinator or worker instances is Unknown.
      • If yes, go to 2.
      • If no, go to 1.
    2. In the upper part of the Presto instance list, choose More > Restart Service to restart the coordinator and worker processes.
    3. In the alarm list, check whether ALM-45325 Presto Service Unavailable is cleared.
      • If yes, no further action is required.
      • If no, go to 1 in Step 2.

  2. Collect fault information.

    1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
    2. Select Presto for Service.
    3. Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
    4. Contact the O&M engineers and send the collected logs.

Alarm Clearing

This alarm is automatically cleared after the fault is rectified.