Help Center/ MapReduce Service/ User Guide/ Alarm Reference (Applicable to MRS 3.x)/ ALM-45333 Number of Presto Worker3 Threads Exceeds the Threshold
Updated on 2024-04-11 GMT+08:00

ALM-45333 Number of Presto Worker3 Threads Exceeds the Threshold

Alarm Description

The system checks the number of threads used by Presto coordinator and worker instances. The default threshold is 1024. This alarm is generated when the number of Presto coordinator or worker threads exceeds the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

45333

Minor

Yes

Alarm Parameters

Parameter

Description

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Impact on the System

None

Possible Causes

  • Too many threads are used by Presto instances.
  • Too many Presto tasks are concurrently executed.

Handling Procedure

Check the number of concurrent tasks.

  1. Check whether the CPU load of the current cluster is normal and the number of concurrent SQL statements meets the expectation.

    • If yes, go to 2.
    • If no, go to 4.

Adjust the alarm threshold for the number of threads.

  1. Log in to FusionInsight Manager and choose O&M > Alarm > Thresholds. On the Thresholds page, choose Presto and click Number of Threads (Coordinator) or Number of Threads (Worker). Then, locate the row that contains the default rule and click Modify in the Operation column to increase the threshold, for example, increase the threshold by 20%.
  2. Check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Upgrade coordinator specifications or add worker node groups.

  1. Check the number of coordinator and worker threads. If the number of coordinator threads is too large, upgrade coordinator node specifications to increase the number of CPU cores. If the number of worker threads is too large, add worker node groups.
  2. Check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select Presto for the target cluster.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M personnel and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None