Full Synchronization Error: column '%s' of relation '%s' does not exist
Scenarios
During full synchronization, an error is reported, and the log information is as follows: service DATAMOVE failed, cause by: apply event=[type=table_data, batch_index_in_shard= %s, table_schema= %s, table_name= %s, record_num= %s] occur error, msg=apply table %s data failed: %s: ERROR: column ' %s' of relation ' %s' does not exist Position: 1043 Call getNextException to see other errors in the batch.
Possible Causes
- During the full synchronization, DDL operations are executed in the destination database. As a result, the table structure in the destination database is inconsistent with that in the source database.
- During the full synchronization, DDL operations are executed in the source database. As a result, the table structure in the destination database is inconsistent with that in the source database.
Contact the customer to confirm whether they executed DDL operations.
Solution
Create a synchronization task again. During the full synchronization, ensure that no DDL operation is executed on the source database and no data is written to the destination database. Otherwise, data may be inconsistent or the synchronization may fail.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.