Updated on 2022-09-21 GMT+08:00

Incremental Synchronization Error: schema '%s' does not exist

Scenarios

During incremental synchronization, an error is reported, and the log information is as follows: service INCREMENT failed, cause by: update %s failed: ERROR: schema ' %s' does not exist.

Possible Causes

The possible causes are as follows:

  • The filter conditions of DDL statements for adding tables in the source database are not synchronized to the destination database.
  • Schemas are deleted from the destination database.

Solution

Create schemas in the destination database based on the source database structure.