ALM-12007 Process Fault (For MRS 2.x or Earlier)
Description
The process health check module checks the process status every 5 seconds. This alarm is generated when the process health check module detects that the process connection status is Bad for three consecutive times.
This alarm is cleared when the process can be connected.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
12007 |
Major |
Yes |
Parameters
Parameter |
Description |
---|---|
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
The service provided by the process is unavailable.
Possible Causes
- The instance process is abnormal.
- The drive space is insufficient.
Procedure
- Check whether the instance process is abnormal.
- Go to the MRS cluster details page. In the alarm list on the alarm management tab page, click the row that contains the alarm. In the alarm details, view the host name and service name of the alarm.
- On the Alarms page, check whether the alarm ALM-12006 Node Fault (For MRS 2.x or Earlier) is generated.
If yes, go to 1.c.
If no, go to 1.d.
- Handle the alarm by following the instructions in ALM-12006 Node Fault (For MRS 2.x or Earlier).
- Check whether the installation directory user, user group, and permission of the alarm role are correct. The correct user, user group, and the permission are omm, ficommon, and 750, respectively.
- Run the following commands to set the permission to 750 and User:Group to omm:ficommon:
chmod 750 <folder_name>
chown omm:ficommon <folder_name>
- Wait 5 minutes and check whether the ALM-12007 Process Fault alarm is cleared.
- If yes, no further action is required.
- If no, go to 2.a.
- Check whether the disk space is insufficient.
- On the MRS cluster details page, click the alarm management tab and check whether ALM-12017 Insufficient Disk Capacity is generated in the alarm list.
- Handle the alarm by following the instructions in ALM-12017 Insufficient Disk Capacity (For MRS 2.x or Earlier).
- Wait 5 minutes and check whether the ALM-12017 Insufficient Disk Capacity alarm is cleared.
If yes, go to 2.d.
If no, go to 3.
- Wait 5 minutes and check whether the alarm is cleared.
If yes, no further action is required.
If no, go to 3.
- Collect fault information.
- On MRS Manager, choose .
- Contact the O&M engineers and send the collected logs.
Reference
None
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