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Common Exceptions in Accessing the MRS Web UI/
[Hue Web UI] Failed to Access the Hue Web UI
Updated on 2023-09-05 GMT+08:00
[Hue Web UI] Failed to Access the Hue Web UI
Symptom
The Hue web UI page fails to be opened.
Possible Causes
- The port is not opened for external users.
- The floating IP address is not correctly set.
- Concurrent mass data query prolongs the query process, occupying the Hive link in Hue. As a result, Hue access is abnormal.
Fault Handling
- On the local server where the browser locates, run the telnet command in the command-line interface (CLI) to check whether the port is opened.
- Run ifconfig in the node where the Hue locates to check whether the floating IP address that is set takes effect.
- It takes about 10 minutes to rectify the fault.
- Check whether a large amount of data is queried at a time.
Procedure
- Log in to the FusionInsight Manager portal.
- Click Cluster, click the name of the desired cluster, and choose Service > Hue. On the displayed page, click Instance to check whether the active/standby status of the Hue service is normal.
- Click Configurations and check whether configuration items HUE_FLOAT_IP and HTTP_PORT are correct.
- If the configuration items are correct, go to 4.
- If the configuration items are incorrect, correct the floating IP address and port number of the Hue service.
- Run the telnet Hue node IP address HTTP_PORT or telnet HUE_FLOAT_IP HTTP_PORT command on the service network to check whether the port is open to external systems.
- If the port is open to external systems, check whether the port is correct and log in to the web UI again.
- If the port is not open to external systems, go to 5.
- Choose Cluster, click the name of the desired cluster, and choose Service > Hue. On the displayed page, click Stop Service.
- Log in to the management node as user root and run the ping HUE_FLOAT_IP command to check whether the IP address can be pinged.
- If the IP address can be pinged, the floating IP is in use. Configure another IP address.
- If the IP address cannot be pinged, go to 7.
- Check whether a large amount of data is queried at a time.
- If yes, optimize Hue query to avoid concurrent mass data query.
- If no, go to 8.
- Contact O&M personnel.
Parent topic: Common Exceptions in Accessing the MRS Web UI
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