How Do I Handle an Import Failure of a Key Pair Created Using PuTTYgen?
Symptom
When a key pair created using PuTTYgen was imported to the management console, the system displayed a message indicating that importing the public key failed.
Possible Causes
The format of the public key content does not meet system requirements.
Storing a public key by clicking Save public key will change the format of the public key content. Importing such a public key will fail because the key does not pass the format verification by the system.
Procedure
Use the locally stored private key and PuTTY Key Generator to restore the format of the public key content. Then, import the public key to the management console.
- Restore the public key file in the correct format.
- Double-click PuTTYgen.exe. The PuTTY Key Generator page is displayed, as shown in Figure 1.
- Click Load and select the private key.
The system automatically loads the private key and restores the format of the public key content in PuTTY Key Generator. The content in the red box in Figure 2 is the public key with the format meeting system requirements.
- Copy the information in the blue square and save it in a local .txt file.
Do not save the public key by clicking Save public key. If you save a public key using Save public key, the public key format will be changed and cannot be imported to the management console directly.
- Import the public key file in the correct format to the KPS console.
- Log in to the management console.
- Click . Choose .
- In the navigation pane, click Key Pair Service.
- On the Key Pair Service page, click Import Key Pair.
- Click Select File, select the .txt public key file, or copy and paste the public key content to the text box of the public key content.
- Click OK to import the public key file.
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