ALM-23007 Garbage Collection (GC) Time of the Loader Process Exceeds the Threshold
Description
The system checks GC time of the Loader process every 60 seconds. The alarm is generated when GC time of the Loader process exceeds the threshold (default value: 12 seconds) for 5 consecutive times. The alarm is cleared when GC time is less than the threshold.
Attribute
Alarm ID |
Alarm Severity |
Automatically Cleared |
---|---|---|
23007 |
Major |
Yes |
Parameters
Name |
Meaning |
---|---|
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Trigger Condition |
Specifies the threshold triggering the alarm. If the current indicator value exceeds this threshold, the alarm is generated. |
Impact on the System
Loader service response is slow.
Possible Causes
The heap memory of the Loader instance is overused or the heap memory is inappropriately allocated.
Procedure
Check GC time.
- On the FusionInsight Manager portal, choose O&M > Alarm > Alarms > Garbage Collection (GC) Time of the Loader Process Exceeds the Threshold > Location. Check the host name of the instance involved in this alarm.
- On the FusionInsight Manager portal, choose Cluster > Name of the desired cluster > Services > Loader > Instance. Click the instance for which the alarm is generated to go to the page for the instance. Click the drop-down menu in the chart area and choose Customize > GC > Garbage Collection (GC) Time of Loader. Click OK.
Figure 1 Garbage Collection (GC) Time of Loader
- Check whether GC time of the Loader process every second exceeds the threshold (default value: 12 seconds).
- On the FusionInsight Manager portal, choose Cluster > Name of the desired cluster > Services > Loader > Configurations. Click All Configurations. Search LOADER_GC_OPTS in the search box. Increase the value of -Xmx as required, and click Save. Click OK.
If this alarm is generated, the heap memory configured for the current Loader instance cannot meet the heap memory required for data transmission. You are advised to handle the problem by referring to 4 in section ALM-23004 Loader Heap Memory Usage Exceeds the Threshold.
- Restart the affected services or instances and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 6.
Collect fault information.
- On the FusionInsight Manager portal, choose O&M > Log > Download.
- Select Loader in the required cluster from the Service drop-down list.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M personnel and send the collected fault logs.
Alarm Clearing
After the fault is rectified, the system automatically clears this alarm.
Related Information
None
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.