Data Encryption Workshop
Data Encryption Workshop
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KMS Related
- What Is Key Management Service?
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- Why Can't I Wrap Asymmetric Keys by Using -id-aes256-wrap-pad in OpenSSL?
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KPS Related
- How Do I Create a Key Pair?
- What Are a Private Key Pair and an Account Key Pair?
- How Do I Handle an Import Failure of a Key Pair Created Using PuTTYgen?
- What Should I Do When I Fail to Import a Key Pair Using Internet Explorer 9?
- How Do I Log In to a Linux ECS with a Private Key?
- How Do I Use a Private Key to Obtain the Password to Log In to a Windows ECS?
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- How Do I Handle the Failure in Replacing a Key Pair?
- How Do I Handle the Failure in Resetting a Key Pair?
- How Do I Handle the Failure in Unbinding a Key Pair?
- Do I Need to Restart Servers After Replacing Its Key Pair?
- How Do I Enable the Password Login Mode for an ECS?
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- What Should I Do If My Private Key Is Lost?
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- Can I Change the Key Pair of a Server?
- Can a Key Pair Be Shared by Multiple Users?
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Dedicated HSM Related
- What Is Dedicated HSM?
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- Do Equipment Room Personnel Has the Super Administrator Role to Steal Information by Using a Privileged UKey?
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What Should I Do If KMS Failed to Be Requested and Error Code 401 Is Displayed?
What Should I Do If KMS Failed to Be Requested and Error Code 401 Is Displayed?
Updated on 2022-09-15 GMT+08:00
Symptom
An error is reported when KMS is requested or the cloud service encryption function is enabled.
Error information: httpcode=401,code=APIGW.0301,Msg=Incorrect IAM authentication information: current ip:xx.xx.xx.xx refused
Possible Causes
Access control is configured in IAM.
By default, IAM allows access from any IP addresses. If you configure ACL, the IP addresses and network segments out of the specified range cannot access KMS or use the cloud encryption feature.
Solution
- To access KMS through the cloud service console (for example, for OBS encryption purposes), allow access from network segments 10.0.0.0/8, 11.0.0.0/8, and 26.0.0.0/8.
- To call KMS via API, allow access from the source IP addresses.
Allowing Access from Specific IP Addresses
- Log in to the management console.
- Click
on the left of the page and choose Management & Governance > Identity and Access Management. The Users page is displayed.
- Choose Security Settings and click the ACL tab. Check whether IP Address Ranges and IPv4 CIDR Blocks are properly configured.
NOTE:
The source IP address you use must be specified on both the Console Access and API Access tabs.
Parent topic: KMS Related
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