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1 Overview

This document describes how to call cloud service APIs that have been registered
with API Gateway, through AK/SK authentication. It explains the signing process
and implementation logic, and provides signature SDKs and invocation examples
of different programming languages, such as Java, Go, Python, and C.

NO TE

1. For the authentication of certain cloud service APIs that are not registered with API
Gateway, see the API Reference of the corresponding service.
The API Reference contains a section named "Calling APIs" that describes API
authentication methods.

2. The SDK of each programming language is packaged in the sample code and can be
obtained separately. You can integrate the SDK into your application by referring to the
API calling example.

3. If you cannot find any signing example of the programming language you use in this
document, please sign requests by referring to AK/SK Authentication.

4. Alternatively, you can call APIs using a token. For details about the use of a token, see
the API Reference of the relevant service.

5. AK/SK authentication supports API requests with a body less than or equal to 12 MB.
For API requests with a larger body, token authentication is recommended.

6. For the APIs provided by a cloud service, see the API Reference of the cloud service.
7. The local time on the client must be synchronized with the clock server to avoid a large

offset in the value of the X-Sdk-Date request header.
API Gateway checks the time format and compares the time in the header with the time
when API Gateway receives the request. If the time difference exceeds 15 minutes, API
Gateway will reject the request.
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2 AK/SK Signing and Authentication
Algorithm

2.1 AK/SK Authentication Process
The AK/SK-based authentication process at the client is as follows:

1. Construct a standard request.
Assemble the request content according to the rules of API Gateway, ensuring
that the client signature is consistent with that in the backend request.

2. Create a to-be-signed string using the standard request and other related
information.

3. Calculate a signature using the AK/SK and to-be-signed string.
4. Add the generated signature to an HTTP request as a header or query

string.

The following describes the process in detail.

NO TE

You can follow the instructions provided in this chapter to sign API requests.
You can also call APIs by using the signing SDKs and sample code of common languages
described in Signing SDKs and Demo.

2.2 Constructing a Standard Request
To access an API through AK/SK authentication, create a standard request, and
then sign the request. The client must follow the same request specifications as
API Gateway so that each HTTP request can obtain the same signing result from
the frontend and backend to complete identity authentication.

The pseudocode of standard HTTP requests is as follows:
CanonicalRequest =
      HTTPRequestMethod + '\n' +
      CanonicalURI + '\n' +
      CanonicalQueryString + '\n' +
      CanonicalHeaders + '\n' +
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      SignedHeaders + '\n' +
      HexEncode(Hash(RequestPayload))

The following procedure uses the Virtual Private Cloud (VPC) query API as an
example to describe how to construct a standard request.

Original request:

GET https://service.region.example.com/v1/77b6a44cba5143ab91d13ab9a8ff44fd/vpcs?
limit=2&marker=13551d6b-755d-4757-b956-536f674975c0 HTTP/1.1
Host: service.region.example.com
X-Sdk-Date: 20191115T033655Z

Step 1 Specify an HTTP request method (HTTPRequestMethod) and end with a carriage
return line feed (CRLF).

HTTP request methods include GET, PUT, POST, and so on. For example:

GET

Step 2 Add a standard URI (CanonicalURI) and end with a CRLF.

Description

Path of the requested resource, which is the URI code of the absolute path.

Format

According to RFC 3986, each part of a valid URI except the redundant and relative
paths must be URI-encoded. If a URI does not end with a slash (/), add a slash at
its end.

Example

See the URI of each API in the API Reference of the corresponding cloud service.
For example, the standard URI code of the VPC query API (/v1/{project_id}/vpcs)
is as follows:

GET
/v1/77b6a44cba5143ab91d13ab9a8ff44fd/vpcs/

NO TE

During signature calculation, the URI must end with a slash (/). When a request is sent, the
URI does not need to end with a slash (/).

Step 3 Add a standard query string (CanonicalQueryString) and end with a CRLF.

Description

Query strings. If no query strings are configured, an empty string is used.

Format

Pay attention to the following to ensure valid query strings:

● Perform URI encoding on each parameter and value according to the
following rules:
– Do not perform URI encoding on any non-reserved characters defined in

RFC 3986, including A–Z, a–z, 0–9, hyphen (-), underscore (_), period (.),
and tilde (~).

– Use %XY to perform percent encoding on all non-reserved characters. X
and Y indicate hexadecimal characters (0–9 and A–F). For example, the

API Request
Signing Guide 2 AK/SK Signing and Authentication Algorithm

Issue 01 (2022-09-08) Copyright © Huawei Technologies Co., Ltd. 3



space character must be encoded as %20, and an extended UTF-8
character must be encoded in the "%XY%ZA%BC" format.

● Add "URI-encoded parameter name=URI-encoded parameter value" to each
parameter. If no value is specified, use an empty string instead. The equal sign
(=) is required.
For example, in the following string that contains two parameters, the value
of parameter parm2 is null.
parm1=value1&parm2=

● Sort the parameters in alphabetically ascending order. For example, a
parameter starting with uppercase letter F precedes another parameter
starting with lowercase letter b.

● Construct a standard query string from the first parameter after sorting.

Example

The URI of the VPC query API contains two optional parameters: limit and
marker. limit indicates the number of records displayed on each page, and
marker indicates the start VPC ID for pagination query.
GET
/v1/77b6a44cba5143ab91d13ab9a8ff44fd/vpcs/
limit=2&marker=13551d6b-755d-4757-b956-536f674975c0

Step 4 Add standard headers (CanonicalHeaders) and end with a CRLF.

Description

List of standard request headers, including all HTTP message headers in the to-be-
signed request. The X-Sdk-Date header must be included to verify the signing
time, which is in the UTC time format YYYYMMDDTHHMMSSZ as specified in ISO
8601.

CA UTION

The local time on the client must be synchronized with the clock server to avoid a
large offset in the value of the X-Sdk-Date request header.
API Gateway checks the time format and compares the time with the time when
API Gateway receives the request. If the time difference exceeds 15 minutes, API
Gateway will reject the request.

Format

CanonicalHeaders consists of multiple message headers, for example,
CanonicalHeadersEntry0 + CanonicalHeadersEntry1 + .... Each message header
(CanonicalHeadersEntry) is in the format of Lowercase(HeaderName) + ':' +
Trimall(HeaderValue) + '\n'.

NO TE

● Lowercase is a function for converting all letters into lowercase letters.
● Trimall is a function for deleting the spaces before and after a value.
● The last message header carries a CRLF. Therefore, an empty line appears because the

CanonicalHeaders field also contains a CRLF according to the specifications.

Example
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Requests for calling the VPC query API need to contain the X-Sdk-Date, Host
(cloud service endpoint), and Content-Type headers.
GET
/v1/77b6a44cba5143ab91d13ab9a8ff44fd/vpcs/
limit=2&marker=13551d6b-755d-4757-b956-536f674975c0
content-type:application/json
host:service.region.example.com
x-sdk-date:20191115T033655Z

NO TICE

Valid message headers must meet the following requirements:
● All letters in a header are converted to lowercase letters, and all spaces before

and after the header are deleted.
● All headers are sorted in alphabetically ascending order.
For example, the original headers are as follows:
Host: service.region.example.com\n
Content-Type: application/json;charset=utf8\n
My-header1:    a   b   c  \n
X-Sdk-Date:20190318T094751Z\n
My-Header2:    "x   y   \n

The message header names are converted into lowercase letters, the message
headers are sorted in alphabetical order, and spaces before and after the header
values are deleted. The standardized message headers are as follows:
content-type:application/json;charset=utf8\n
host:service.region.example.com\n
my-header1:a   b   c\n
my-header2:"x   y\n
x-sdk-date:20190318T094751Z\n

Step 5 Add message headers (SignedHeaders) for request signing, and end with a CRLF.

Description

List of message headers used for request signing. This step is to determine which
headers are used for signing the request and which headers can be ignored during
request verification. The X-Sdk-date header must be included.

Format

SignedHeaders = Lowercase(HeaderName0) + ';' + Lowercase(HeaderName1) + ";"
+ ...

Letters in the message headers are converted to lowercase letters. All headers are
sorted alphabetically and separated with commas.

Lowercase is a function for converting all letters into lowercase letters.

Example

In the following request, the Content-Type, Host, and X-Sdk-Date headers are
used for request signing.
GET
/v1/77b6a44cba5143ab91d13ab9a8ff44fd/vpcs/
limit=2&marker=13551d6b-755d-4757-b956-536f674975c0
content-type:application/json
host:service.region.example.com
x-sdk-date:20191115T033655Z
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content-type;host;x-sdk-date

The signed headers are as follows:

SignedHeaders=content-type;host;x-sdk-date

For details about how to add headers to a request, see Adding the Signature to
the Request Header.

Step 6 Use a hash function, such as SHA-256, to create a hash value based on the body
(RequestPayload) of the HTTP or HTTPS request.

Description

Request message body. The message body needs two layers of conversion
(HexEncode(Hash(RequestPayload))). Hash is a function for generating
message digest. Currently, SHA-256 is supported. HexEncode is the Base16
encoding function for returning a digest consisting of lowercase letters. For
example, HexEncode("m") returns 6d instead of 6D. Each byte you enter is
expressed as two hexadecimal characters.

NO TE

If RequestPayload is null, the null value is used for calculating a hash value.

Example

This example uses GET as an example, and the request body is empty. After hash
processing, the request body (empty string) is as follows:

GET
/v1/77b6a44cba5143ab91d13ab9a8ff44fd/vpcs/
limit=2&marker=13551d6b-755d-4757-b956-536f674975c0
content-type:application/json
host:service.region.example.com
x-sdk-date:20191115T033655Z

content-type;host;x-sdk-date
e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855

A standard request is constructed.

Step 7 Perform hash processing on the standard request in the same way as that on the
RequestPayload. After hash processing, the standard request is expressed with
lowercase hexadecimal strings.

Algorithm pseudocode:
Lowercase(HexEncode(Hash.SHA256(CanonicalRequest)))

Example of the standard request after hash processing:

b25362e603ee30f4f25e7858e8a7160fd36e803bb2dfe206278659d71a9bcd7a

----End

2.3 Creating a To-Be-Signed String
After a standard HTTP request is constructed and the request hash value is
obtained, create a to-be-signed string by combining them with the signature
algorithm and signing time.

API Request
Signing Guide 2 AK/SK Signing and Authentication Algorithm

Issue 01 (2022-09-08) Copyright © Huawei Technologies Co., Ltd. 6



StringToSign =
    Algorithm + \n +
    RequestDateTime + \n +
    HashedCanonicalRequest

Parameters in the pseudocode are described as follows:

● Algorithm
Signature algorithm. For SHA-256, the value is SDK-HMAC-SHA256.

● RequestDateTime
Request timestamp, which is the same as X-Sdk-Date in the request header.
The format is YYYYMMDDTHHMMSSZ.

● HashedCanonicalRequest
Hash value generated using the SHA-256 algorithm based on the standard
request constructed in Constructing a Standard Request.

In this example, the following to-be-signed string is obtained:
SDK-HMAC-SHA256
20191115T033655Z
b25362e603ee30f4f25e7858e8a7160fd36e803bb2dfe206278659d71a9bcd7a

2.4 Calculating the Signature
Use the SK and to-be-signed string as the input of the encryption hash function,
and convert the calculated binary signature into a hexadecimal expression.

The pseudocode is as follows:

signature = HexEncode(HMAC(Secret Access Key, string to sign))

HMAC indicates hash calculation, and HexEncode indicates hexadecimal
conversion. Table 2-1 describes the parameters in the pseudocode.

Table 2-1 Parameter description

Parameter Description

Secret Access Key Signature key

string to sign Character string to be signed

 

If the SK is MFyfvK41ba2giqM7Uio6PznpdUKGpownRZlmVmHc, the calculated
signature is as follows:

7be6668032f70418fcc22abc52071e57aff61b84a1d2381bb430d6870f4f6ebe

2.5 Adding the Signature to the Request Header
Add the signature to the Authorization HTTP header. The Authorization header
is used for identity authentication and not included in the SignedHeaders.

The pseudocode is as follows:

API Request
Signing Guide 2 AK/SK Signing and Authentication Algorithm

Issue 01 (2022-09-08) Copyright © Huawei Technologies Co., Ltd. 7



Pseudocode for Authorization header creation:
Authorization: algorithm Access=Access key, SignedHeaders=SignedHeaders, Signature=signature

There is no comma but a space before the algorithm and Access. SignedHeaders
and Signature must be separated with commas.

The signed headers are as follows:

SDK-HMAC-SHA256 Access=QTWAOYTTINDUT2QVKYUC, SignedHeaders=content-type;host;x-sdk-date, 
Signature=7be6668032f70418fcc22abc52071e57aff61b84a1d2381bb430d6870f4f6ebe

The signed headers are added to the HTTP request for identity authentication. If
the identity authentication is successful, the request is sent to the corresponding
cloud service for processing.

The complete request that contains the signature information is as follows:

GET /v1/77b6a44cba5143ab91d13ab9a8ff44fd/vpcs?limit=2&; marker=13551d6b-755d-4757-
b956-536f674975c0 HTTP/1.1
Host: service.region.example.com
Content-Type: application/json
x-sdk-date: 20191115T033655Z
Authorization: SDK-HMAC-SHA256 Access=QTWAOYTTINDUT2QVKYUC, SignedHeaders=content-
type;host;x-sdk-date, Signature=7be6668032f70418fcc22abc52071e57aff61b84a1d2381bb430d6870f4f6ebe

Example request for calling an API with a curl command:

curl -X GET "https://service.region.example.com/v1/77b6a44cba5143ab91d13ab9a8ff44fd/vpcs?
limit=2&marker=13551d6b-755d-4757-b956-536f674975c0" -H "content-type: application/json" -H "X-Sdk-
Date: 20191115T033655Z" -H "host: service.region.example.com" -H "Authorization: SDK-HMAC-SHA256 
Access=QTWAOYTTINDUT2QVKYUC, SignedHeaders=content-type;host;x-sdk-date, 
Signature=7be6668032f70418fcc22abc52071e57aff61b84a1d2381bb430d6870f4f6ebe" -d $''
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3 AK/SK Signing and Authentication Guide

3.1 AK/SK Signing and Authentication Process
The AK/SK signing and authentication process is as follows:

1. API calling information is collected.
The information to be collected includes:
– Endpoint and URI that will constitute the request URL
– AK/SK used for signing and authentication
– Project ID and subproject ID
– Account name and account ID

Table 3-1 Required information to collect

Item Description

Endpoint Endpoint of a cloud service in a region.
For details on how to obtain an endpoint, see Obtaining
an Endpoint.

URI API request path and parameters.
Obtain the request path and parameters from the API
Reference of the cloud service.

AK/SK Access key ID (AK) and secret access key (SK), which are
used to sign API requests.
For details on how to obtain the AK/SK, see Obtaining
an AK/SK.

Project_Id Project ID, which needs to be configured for the URI of
most APIs to identify different projects.
For details on how to obtain a project ID, see Obtaining
a Project ID.
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Item Description

X-Project-Id Subproject ID, which is used in multi-project scenarios. To
access resources in a subproject through AK/SK-based
authentication, the X-Project-Id field must be added to
the request header.
For details on how to obtain a subproject ID, see
Obtaining a Project ID.

X-Domain-Id Account ID, which is used to:
● Obtain a token for token authentication.
● Call APIs of global services through AK/SK

authentication. Global services (such as OBS and
CDN) are deployed without specifying physical
regions.

For details on how to obtain the account ID, see
Obtaining the Account Name and Account ID.

 
2. APIs are called.

This document provides signature SDKs and API calling examples in multiple
languages, such as Java, Go, Python, and C. You can find the language you
need in Signing SDKs and Demo and integrate the SDK into your application
by referring to the examples and API calling description.

NO TE

APIs can be called through IAM authentication or using AK/SK. For details, see How
Do I Use a Temporary AK/SK to Sign Requests?.

3.2 Obtaining an Endpoint
An endpoint is the access domain name of a cloud service in a region. Each service
has different domain names in different regions.

Contact the environment administrator to obtain the region and endpoint.

NO TE

For all example request URLs in this document, the endpoint service.region.example.com
is used as an example.

3.3 Obtaining an AK/SK
If an AK/SK has already been generated, skip this step. Find the downloaded
AK/SK file, which is usually named credentials.csv.

The following figure shows an AK and SK.

Figure 3-1 Content of the credential.csv file

API Request
Signing Guide 3 AK/SK Signing and Authentication Guide

Issue 01 (2022-09-08) Copyright © Huawei Technologies Co., Ltd. 10



Procedure

Step 1 Register an account and log in to the management console.

Step 2 Hover the mouse pointer over the username, click the username, and choose My
Credentials from the drop-down list.

Step 3 In the navigation pane on the left, choose Access Keys.

Step 4 Click Create Access Key.

Step 5 Enter a description, and click OK to download the access key. Keep the access key
secure.

NO TE

For details about how to obtain a temporary AK/SK, see the Identity and Access
Management API Reference.

----End

3.4 Obtaining a Project ID
A project ID is required in the URLs of some APIs when the APIs are called. It is
also required when you obtain a token. Perform the following steps to obtain a
project ID:

1. Register an account and log in to the management console.

2. Hover the mouse pointer over the username, click the username, choose My
Credentials from the drop-down list, and then view the project ID.
Projects physically isolate cloud server resources by region. Multiple projects
can be created in the same region to implement more fine-grained isolation.

3.5 Obtaining the Account Name and Account ID
The account name and account ID are required for some URLs when an API is
called. To obtain the account name and account ID, perform the following
operations:

1. Register an account and log in to the management console.

2. Hover the mouse pointer over the username, click the username, and choose
My Credentials from the drop-down list.
View the account name and account ID.

3.6 Signing SDKs and Demo

3.6.1 Java
This section uses Eclipse as an example to describe how to integrate the Java SDK
for API request signing. You can import the sample project in the code package,
and integrate the signing SDK into your application by referring to the API calling
example.
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Preparing the Environment
● Download the Eclipse installation file or package, and install the tool or

decompress the package.
● Download Java Development Kit 1.8.111 or a later version from the Oracle

official website.

Obtaining the SDK
Log in to the API Gateway console and choose Help Center > SDK Process Flow.
Then download the SDK. For details, see section "SDKs" in the User Guide.

The following table shows the directory structure of the package.

Name Description

libs\java-sdk-core-x.x.x.jar Signing SDK and dependencies

libs\commons-codec-x.x.jar

libs\commons-logging-x.x.jar

libs\httpclient-x.x.x.jar

libs\httpcore-x.x.x.jar

src\com\apig\sdk\demo\Main.java Sample code for signing requests

.classpath Sample project files

.project

 

Configuring Eclipse
Importing the Sample Project

Step 1 Start Eclipse and choose File > Import. In the Import dialog box, choose General
> Existing Projects into Workspace, and select the APIGW-java-sdk-x.x.x folder.
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Figure 3-2 Import

Figure 3-3 Import Projects

Step 2 Click Finish. The following figure shows the imported sample project.
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Figure 3-4 Sample project for signing requests

----End

NO TE

If Eclipse is installed, the JDK environment has been configured. Therefore, no more
descriptions about JDK environment are provided.

Creating a Project with the Signing SDK

Step 1 Start Eclipse and create a Java project. Specify a project name, for example, java-
sdk-demo. Retain the default values for other parameters and click Finish.
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Step 2 Import the .jar files in the Java SDK.

1. Right-click the created project java-sdk-demo and choose Build Path > Add
External Archives.
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2. Select all .jar files in the java\libs directory.

3. Click Open.

Step 3 Create a package and a class named Main.

1. Right-click src and choose New > Package.

2. Enter com.apig.sdk.demo for Name.
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3. Click Finish.
The package is created.

4. Right-click com.apig.sdk.demo and choose New > Class.

5. Enter Main for Name and select public static void main(String[] args).
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6. Click Finish.
The Main file is created.

Step 4 The project is created.

Before using Main.java, enter the required code according to Calling APIs.

----End

Calling APIs
The sample project can be invoked after you change the environment
information. The following is a procedure for invoking the SDK in an application
to sign requests.

Step 1 Add the following references to Main.java:
import java.io.IOException;
import javax.net.ssl.SSLContext;

import org.apache.http.Header;
import org.apache.http.HttpEntity;
import org.apache.http.HttpResponse;
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import org.apache.http.client.methods.HttpRequestBase;
import org.apache.http.conn.ssl.AllowAllHostnameVerifier;
import org.apache.http.conn.ssl.SSLConnectionSocketFactory;
import org.apache.http.conn.ssl.SSLContexts;
import org.apache.http.conn.ssl.TrustSelfSignedStrategy;
import org.apache.http.impl.client.CloseableHttpClient; 
import org.apache.http.impl.client.HttpClients; 
import org.apache.http.util.EntityUtils; 

import com.cloud.apigateway.sdk.utils.Client; 
import com.cloud.apigateway.sdk.utils.Request;

Step 2 Create a request and set required parameters.

Sample code and annotations:
Request request = new Request();
        try {
            //Set the AK/SK to sign and authenticate the request.
            request.setKey("QTWAOYTTINDUT2QVKYUC");
            request.setSecret("MFyfvK41ba2giqM7Uio6PznpdUKGpownRZlmVmHc");

            //The following example shows how to set the request URL and parameters to query a VPC list.

            //Specify a request method, such as GET, PUT, POST, DELETE, HEAD, and PATCH.
            request.setMethod("GET");

            //Set a request URL in the format of https://{Endpoint}/{URI}.
            request.setUrl("https://endpoint.example.com/v1/77b6a44cba5143ab91d13ab9a8ff44fd/vpcs?
limit=2");

            //Set parameters for the request URL.
            request.addQueryStringParam("limit", "2");

            //Add header parameters, for example, Content-Type application/json.
            request.addHeader("Content-Type", "application/json");

            //Add a body if you have specified the PUT or POST method. Special characters, such as the double 
quotation mark ("), contained in the body must be escaped.
            //request.setBody("demo");
           //setBody can only be a string.

        } catch (Exception e) {
            e.printStackTrace();
            return;
        }

Step 3 Sign the request, access the API, and print the result.

The sample code is as follows:
        CloseableHttpClient client = null;
        try
        {
            HttpRequestBase signedRequest = Client.sign(request);

            client = HttpClients.custom().build();
            HttpResponse response = client.execute(signedRequest);
            System.out.println(response.getStatusLine().toString());
            Header[] resHeaders = response.getAllHeaders();
            for (Header h : resHeaders)
            {
                System.out.println(h.getName() + ":" + h.getValue());
            }
            HttpEntity resEntity = response.getEntity();
            if (resEntity != null)
            {
                System.out.println(System.getProperty("line.separator") + EntityUtils.toString(resEntity, "UTF-8"));
            }
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        } catch (Exception e)
        {
            e.printStackTrace();
        } finally
        {
            try
            {
                if (client != null)
                {
                    client.close();
                }
            } catch (IOException e)
            {
                e.printStackTrace();
            }
        }

Step 4 Right-click Main.java and choose Run As > Java Application.

Run the project test code.

Step 5 On the Console tab page, view the running result.
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----End

3.6.2 Go
This section uses IntelliJ IDEA as an example to describe how to integrate the Go
SDK for API request signing. You can import the sample project in the code
package, and integrate the signing SDK into your application by referring to the
API calling example.

Preparing the IDEA Development Environment
● Download IntelliJ IDEA from the IntelliJ IDEA official website and install it.
● Download the Go installation package from the Go official website and

install it.
● To install the Go plug-in on IDEA, choose File > Settings.

Figure 3-5 Installing the Go plug-in on IDEA
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Obtaining the SDK
Log in to the API Gateway console and choose Help Center > SDK Process Flow.
Then download the SDK. For details, see section "SDKs" in the User Guide.

Develop your application using the SDK and sample code.

Name Description

core\escape.go Used for escaping special
characters.

core\signer.go Signing SDK

demo.go Sample code

 

Importing the Sample Project on IDEA

Step 1 Start IDEA and choose File > New > Project.

On the displayed New Project page, choose Go and click Next.

Step 2 Click ..., select the directory where the SDK is decompressed, and click Finish.
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Step 3 View the directory structure shown in the following figure.

----End

Request Signing and API Calling

Step 1 Import the Go SDK (signer.go) to the project.
import "./core"

Step 2 Generate a new signer and enter the AK and SK.
s := core.Signer{
        Key: "QTWAOY********KYUC",
        Secret: "MFyfvK41ba2giqM7**********KGpownRZlmVmHc",
}

Step 3 Generate a new request, and specify the domain name, method, request URI, and
body.
//The following example shows how to set the request URL and parameters to query a VPC list.
//Add a body if you have specified the PUT or POST method. Special characters, such as the double 

API Request
Signing Guide 3 AK/SK Signing and Authentication Guide

Issue 01 (2022-09-08) Copyright © Huawei Technologies Co., Ltd. 23



quotation mark ("), contained in the body must be escaped.
r, _ := http.NewRequest("GET", "https://service.region.example.com/v1/{project_id}/vpcs?a=1", 
ioutil.NopCloser(bytes.NewBuffer([]byte(""))))

Step 4 Add other headers required for request signing or other purposes. For example,
add the X-Project-Id header in multi-project scenarios or the X-Domain-Id
header for a global service.
/Add header parameters, for example, X-Domain-Id for invoking a global service and X-Project-Id for 
invoking a project-level service.
r.Header.Add("X-Project-Id", "xxx")

Step 5 Execute the following function to add the X-Sdk-Date and Authorization headers
for signing:
s.Sign(r)

Step 6 Access the API and view the access result.
resp, err := http.DefaultClient.Do(r)
body, err := ioutil.ReadAll(resp.Body)

----End

3.6.3 Python
This section uses IntelliJ IDEA as an example to describe how to integrate the
Python SDK for API request signing. You can import the sample project in the code
package, and integrate the signing SDK into your application by referring to the
API calling example.

Preparing the Environment
● Download IntelliJ IDEA from the IntelliJ IDEA official website and install it.
● Download the Python installation package (version 2.7.9 or later, or 3.x) from

the Python official website and install it.
After Python is installed, run the pip command to install the requests library.
pip install requests

NO TE

If a certificate error occurs during the installation, download the get-pip.py file to
upgrade the pip environment, and try again.

● Install the Python plug-in on IDEA.
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Obtaining the SDK
Log in to the API Gateway console and choose Help Center > SDK Process Flow.
Then download the SDK. For details, see section "SDKs" in the User Guide.

The following table shows the directory structure of the downloaded package.

Name Description

apig_sdk\__init__.py SDK code

apig_sdk\signer.py

main.py Sample code

licenses\license-requests Third-party license

 

Importing the Sample Project
Step 1 Start IDEA and choose File > New > Project.

On the displayed New Project page, choose Python and click Next.

Step 2 Click Next. Click ..., select the directory where the SDK is decompressed, and click
Finish.
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Step 3 View the directory structure shown in the following figure.

----End

Request Signing and API Calling

Step 1 Run the pip command to install the requests library.
pip install requests

Step 2 Import apig_sdk to the project.
from apig_sdk import signer
import requests

Step 3 Generate a new signer and enter the AK and SK.
sig = signer.Signer()
# Set the AK/SK to sign and authenticate the request.
sig.Key = "QTWAOY********VKYUC"
sig.Secret = "MFyfvK41ba2giqM7**********KGpownRZlmVmHc"

Step 4 Generate a new request, and specify the domain name, method, request URI, and
body.

The following is an example request for querying VPCs. The HTTP method is GET,
the domain name (endpoint) is service.region.example.com, and the API URI is /
v1/77b6a44cba5143ab91d13ab9a8ff44fd/vpcs?limit=1.

For details, see section "Querying VPCs" in the VPC API Reference.
# The following example shows how to set the request URL and parameters to query a VPC list.
r = signer.HttpRequest("GET", "https://{service}.region.example.com/
v1/77b6a44cba5143ab91d13ab9a8ff44fd/vpcs?limit=1")
# r.body = "{\"a\":1}"

Step 5 Add other headers required for request signing or other purposes. For example,
add the X-Project-Id header in multi-project scenarios or the X-Domain-Id
header for a global service. Separate multiple headers with commas.
r.headers = {"X-Project-Id": "xxx"}
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Step 6 Execute the following function to add the X-Sdk-Date and Authorization headers
for signing:
sig.Sign(r)

NO TE

● X-Sdk-Date is a request header parameter required for signing requests.

● The SDK automatically completes signing requests, and you do not need to know which
header parameters are involved in the signing process.

Step 7 Access the API and view the access result.
resp = requests.request(r.method, r.scheme + "://" + r.host + r.uri, headers=r.headers, data=r.body)
print(resp.status_code, resp.reason)
print(resp.content)

----End

3.6.4 C#
This section uses Visual Studio as an example to describe how to integrate the C#
SDK for API request signing. You can import the sample project in the code
package, and integrate the signing SDK into your application by referring to the
API calling example.

Preparing the Environment

Download Visual Studio from the Visual Studio official website and install it.

Obtaining the SDK

Log in to the API Gateway console and choose Help Center > SDK Process Flow.
Then download the SDK. For details, see section "SDKs" in the User Guide.

The following table shows the directory structure of the downloaded package.

Name Description

apigateway-signature\Signer.cs SDK code

apigateway-signature\HttpEncoder.cs

sdk-request\Program.cs Sample code for signing requests

csharp.sln Project file

licenses\license-referencesource Third-party license

 

Opening the Sample Project

Double-click csharp.sln in the SDK package to open the project. apigateway-
signature is a shared library that implements the signature algorithm. It can be
used in .Net Framework and .Net Core projects. The sdk-request project is used as
an example.
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Request Signing and API Calling

Step 1 Import the SDK to the project.
using System;
using System.Net;
using System.IO;
using System.Net.Http;
using System.Threading;
using APIGATEWAY_SDK;

Step 2 Generate a new signer and enter the AK and SK.
Signer signer = new Signer();
signer.Key = "QTWAOYT**********VKYUC";
signer.Secret = "MFyfvK41ba2giqM7**********KGpownRZlmVmHc";

Step 3 Generate a new request, and specify the domain name, method, request URI, and
body.
//The following example shows how to set the request URL and parameters to query a VPC list.
HttpRequest r = new HttpRequest("GET", new Uri("https://{service}.region.example.com/
v1/77b6a44cba5**********9a8ff44fd/vpcs?limit=1"));
//Add a body if you have specified the PUT or POST method. Special characters, such as the double 
quotation mark ("), contained in the body must be escaped.
r.body = "";

Step 4 Add other headers required for request signing or other purposes. For example,
add the X-Project-Id header in multi-project scenarios or the X-Domain-Id
header for a global service.
//Add header parameters, for example, X-Domain-Id for invoking a global service and X-Project-Id for 
invoking a project-level service.
r.headers.Add("X-Project-Id", "xxx");

Step 5 Execute the following function to generate HttpWebRequest, and add the X-Sdk-
Date and Authorization headers for signing the request:

If you use HttpClient, you can obtain header information from the request. For
details about headers, see AK/SK Signing and Authentication Algorithm.
HttpWebRequest req = signer.Sign(r);

Step 6 Access the API and view the access result.
try
{
    var writer = new StreamWriter(req.GetRequestStream());
    writer.Write(r.body);
    writer.Flush();
    HttpWebResponse resp = (HttpWebResponse)req.GetResponse();
    var reader = new StreamReader(resp.GetResponseStream());
    Console.WriteLine(reader.ReadToEnd());
}
catch (WebException e)
{
    HttpWebResponse resp = (HttpWebResponse)e.Response;
    if (resp != null)
    {
        Console.WriteLine((int)resp.StatusCode + " " + resp.StatusDescription);
        var reader = new StreamReader(resp.GetResponseStream());
        Console.WriteLine(reader.ReadToEnd());
    }
    else
    {
        Console.WriteLine(e.Message);
    }
}
Console.WriteLine("----------------");

----End
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3.6.5 JavaScript
This section uses IntelliJ IDEA as an example to describe how to integrate the
JavaScript SDK for API request signing. You can import the sample project in the
code package, and integrate the signing SDK into your application by referring to
the API calling example.

The descriptions in this section are provided based on the Node.js environment.

Preparing the Environment
● Download IntelliJ IDEA from the IntelliJ IDEA official website and install it.
● Download the Node.js installation package from the Node.js official website

and install it.
After Node.js is installed, run the npm command to install the moment and
moment-timezone modules.
npm install moment --save
npm install moment-timezone --save

● Install the Node.js plug-in on IDEA.

Obtaining the SDK

Log in to the API Gateway console and choose Help Center > SDK Process Flow.
Then download the SDK. For details, see section "SDKs" in the User Guide.

Decompress the downloaded package to the current folder. The following table
shows the directory structure.

Name Description

signer.js SDK code

node_demo.js Node.js sample code

test.js Test case

licenses\license-crypto-js Third-party licenses

licenses\license-node
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Creating a Project

Step 1 Start IDEA and choose File > New > Project.

In the New Project dialog box, choose Static Web and click Next.

Step 2 Click ..., select the directory where the SDK is decompressed, and click Finish.

Step 3 View the directory structure shown in the following figure.
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Step 4 In the upper right corner of the IDEA window, click Edit Configurations or Add
Configurations.

Step 5 Click + and select Node.js.

Step 6 Set JavaScript file to node_demo.js and click OK.
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----End

Calling APIs (Node.js)

Step 1 Run the npm command to install the moment and moment-timezone modules.
npm install moment --save
npm install moment-timezone --save

Step 2 Import signer.js to your project.
var signer = require('./signer')
var http = require('http')

Step 3 Generate a new signer and enter the key and secret.
var sig = new signer.Signer()
sig.Key = "QTWAOYT*******QVKYUC"
sig.Secret = "MFyfvK41ba2giqM7**********KGpownRZlmVmHc"

Step 4 Generate a new request, and specify the domain name, method, request URI, and
body.
//The following example shows how to set the request URL and parameters to query a VPC list.
var r = new signer.HttpRequest("GET", "service.region.example.com/
v1/77b6a44cba5143ab91d13ab9a8ff44fd/vpcs?limie=1");

//Add a body if you have specified the PUT or POST method. Special characters, such as the double 
quotation mark ("), contained in the body must be escaped.
r.body = '';

Step 5 Add other headers required for request signing or other purposes. For example,
add the X-Project-Id header in multi-project scenarios or the X-Domain-Id
header for a global service.
//Add header parameters, for example, X-Domain-Id for invoking a global service and X-Project-Id for 
invoking a project-level service.
r.headers = {"X-Project-Id": "xxx"};

Step 6 Execute the following function to generate HTTPS request parameters, and add
the X-Sdk-Date and Authorization headers for signing the request:
var opt = sig.Sign(r)
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Step 7 Access the API and view the access result.
var req = https.request(opt, function(res){
        console.log(res.statusCode)  
        res.on("data",    function(chunk){
        console.log(chunk.toString())
    })
})
req.on("error",function(err){
    console.log(err.message)
})
req.write(r.body)
req.end()

----End

3.6.6 PHP
This section uses IntelliJ IDEA as an example to describe how to integrate the PHP
SDK for API request signing. You can import the sample project in the code
package, and integrate the signing SDK into your application by referring to the
API calling example.

Preparing the Environment
● Download IntelliJ IDEA from the IntelliJ IDEA official website and install it.
● Download the PHP installation package from the PHP official website and

install it.
● Copy the php.ini-production file from the PHP installation directory to the C:

\windows\ directory, rename the file as php.ini, and then add the following
lines to the file:
extension_dir = "{PHP installation directory}/ext"
extension=openssl
extension=curl

● Install the PHP plug-in on IDEA.

Obtaining the SDK

Log in to the API Gateway console and choose Help Center > SDK Process Flow.
Then download the SDK. For details, see section "SDKs" in the User Guide.

Decompress the downloaded package to the current folder. The following table
shows the directory structure.
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Name Description

signer.php SDK code

index.php Sample code

 

Creating a Project

Step 1 Start IDEA and choose File > New > Project.

On the displayed New Project page, choose PHP and click Next.

Step 2 Click ..., select the directory where the SDK is decompressed, and click Finish.
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Step 3 View the directory structure shown in the following figure.

----End

Request Signing and API Calling

Step 1 Import the PHP SDK to your code.
require 'signer.php';

Step 2 Generate a new signer and enter the AK and SK.
$signer = new Signer();
$signer->Key = 'QTWAOY*********QVKYUC';
$signer->Secret = "MFyfvK41ba2giqM7**********KGpownRZlmVmHc";

Step 3 Generate a new request, and specify the domain name, method, request URI, and
body.
//The following example shows how to set the request URL and parameters to query a VPC list.
$req = new Request('GET', 'https://service.region.example.com/v1/{project_id}/vpcs?limit=1');
//Add a body if you have specified the PUT or POST method. Special characters, such as the double 
quotation mark ("), contained in the body must be escaped.
$req->body = '';

Step 4 Add other headers required for request signing or other purposes. For example,
add the X-Project-Id header in multi-project scenarios or the X-Domain-Id
header for a global service.
//Add header parameters, for example, X-Domain-Id for invoking a global service and X-Project-Id for 
invoking a project-level service.
$req->headers = array(
   'X-Project-Id' => 'xxx',
);

Step 5 Execute the following function to generate a $curl context variable.
$curl = $signer->Sign($req);

Step 6 Access the API and view the access result.
$response = curl_exec($curl);
echo curl_getinfo($curl, CURLINFO_HTTP_CODE);
echo $response;
curl_close($curl);

----End
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3.6.7 C++

Preparing the Environment
This section uses Linux Ubuntu as an example. Before calling APIs, install the
required SSL tools.

1. Install the OpenSSL library.
apt-get install libssl-dev

2. Install the curl library.
apt-get install libcurl4-openssl-dev

Obtaining the SDK
Log in to the API Gateway console and choose Help Center > SDK Process Flow.
Then download the SDK. For details, see section "SDKs" in the User Guide.

Decompress the downloaded package to the current folder. The following table
shows the directory structure.

Name Description

hasher.cpp SDK code

hasher.h

header.h

RequestParams.cpp

RequestParams.h

signer.cpp

signer.h

constants.h

Makefile Makefile file

main.cpp Sample code

 

Request Signing and API Calling

Step 1 Add the following references to main.cpp:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <curl/curl.h>
#include "signer.h"

Step 2 Generate a new signer and enter the AK and SK.
//Set the AK/SK to sign and authenticate the request.
Signer signer("QTWAOYT********VKYUC", "MFyfvK41ba2giqM7**********KGpownRZlmVmHc");

Step 3 Generate a new RequestParams request, and specify the method, domain name,
request URI, query strings, and request body.
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//Specify a request method, such as GET, PUT, POST, DELETE, HEAD, and PATCH.
//Set a request URL.
//Set parameters for the request URL.
//Add a body if you have specified the PUT or POST method. Special characters, such as the double 
quotation mark ("), contained in the body must be escaped.
RequestParams* request = new RequestParams("GET", "service.region.example.com", "/v1/{project_id}/vpcs",
        "limit=2", "");

Step 4 Add other headers required for request signing or other purposes. For example,
add the X-Project-Id header in multi-project scenarios or the X-Domain-Id
header for a global service.
//Add header parameters, for example, X-Domain-Id for invoking a global service and X-Project-Id for 
invoking a project-level service.
request->addHeader("X-Project-Id", "xxx");

Step 5 Execute the following function to add the generated headers as request variables.
signer.createSignature(request);

Step 6 Use the curl library to access the API and view the access result.
static size_t
WriteMemoryCallback(void *contents, size_t size, size_t nmemb, void *userp)
{
    size_t realsize = size * nmemb;
    struct MemoryStruct *mem = (struct MemoryStruct *)userp;

    mem->memory = (char*)realloc(mem->memory, mem->size + realsize + 1);
    if (mem->memory == NULL) {
        /* out of memory! */
        printf("not enough memory (realloc returned NULL)\n");
        return 0;
    }

    memcpy(&(mem->memory[mem->size]), contents, realsize);
    mem->size += realsize;
    mem->memory[mem->size] = 0;

    return realsize;
}

//send http request using curl library
int perform_request(RequestParams* request)
{
    CURL *curl;
    CURLcode res;
    struct MemoryStruct resp_header;
    resp_header.memory = (char*)malloc(1);
    resp_header.size = 0;
    struct MemoryStruct resp_body;
    resp_body.memory = (char*)malloc(1);
    resp_body.size = 0;

    curl_global_init(CURL_GLOBAL_ALL);
    curl = curl_easy_init();

    curl_easy_setopt(curl, CURLOPT_CUSTOMREQUEST, request->getMethod().c_str());
    std::string url = "http://" + request->getHost() + request->getUri() + "?" + request->getQueryParams();
    curl_easy_setopt(curl, CURLOPT_URL, url.c_str());
    struct curl_slist *chunk = NULL;
    std::set<Header>::iterator it;
    for (auto header : *request->getHeaders()) {
        std::string headerEntry = header.getKey() + ": " + header.getValue();
        printf("%s\n", headerEntry.c_str());
        chunk = curl_slist_append(chunk, headerEntry.c_str());
    }
    printf("-------------\n");
    curl_easy_setopt(curl, CURLOPT_HTTPHEADER, chunk);
    curl_easy_setopt(curl, CURLOPT_COPYPOSTFIELDS, request->getPayload().c_str());
    curl_easy_setopt(curl, CURLOPT_NOBODY, 0L);
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    curl_easy_setopt(curl, CURLOPT_WRITEFUNCTION, WriteMemoryCallback);
    curl_easy_setopt(curl, CURLOPT_HEADERDATA, (void *)&resp_header);
    curl_easy_setopt(curl, CURLOPT_WRITEDATA, (void *)&resp_body);
    //curl_easy_setopt(curl, CURLOPT_VERBOSE, 1L);
    res = curl_easy_perform(curl);
    if (res != CURLE_OK) {
        fprintf(stderr, "curl_easy_perform() failed: %s\n", curl_easy_strerror(res));
    }
    else {
        long status;
        curl_easy_getinfo(curl, CURLINFO_HTTP_CODE, &status);
        printf("status %d\n", status);
        printf(resp_header.memory);
        printf(resp_body.memory);
    }
    free(resp_header.memory);
    free(resp_body.memory);
    curl_easy_cleanup(curl);

    curl_global_cleanup();

    return 0;
}

Step 7 Run the make command to obtain a main executable file, execute the file, and
then view the execution result.

----End

3.6.8 C

Preparing the Environment

This section uses Linux Ubuntu as an example. Before calling APIs, install the
required SSL tools.

1. Install the OpenSSL library.
apt-get install libssl-dev

2. Install the curl library.
apt-get install libcurl4-openssl-dev

Obtaining the SDK

Log in to the API Gateway console and choose Help Center > SDK Process Flow.
Then download the SDK. For details, see section "SDKs" in the User Guide.

Decompress the downloaded package to the current folder. The following table
shows the directory structure.

Name Description

signer_common.c SDK code

signer_common.h

signer.c

signer.h

Makefile Makefile file
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Name Description

main.c Sample code

 

Request Signing and API Calling

Step 1 Add the following references to main.c:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <curl/curl.h>
#include "signer.h"

Step 2 Generate a sig_params_t variable, and enter the AK and SK.
sig_params_t params;
sig_params_init(&params);
sig_str_t ak = sig_str("QTWAOY******QVKYUC");
sig_str_t sk = sig_str("MFyfvK41ba2giqM7**********KGpownRZlmVmHc");
params.key = ak;
params.secret = sk;

Step 3 Specify the method, domain name, request URI, query strings, and request body.
sig_str_t host = sig_str("service.region.example.com");
sig_str_t method = sig_str("GET");
sig_str_t uri = sig_str("/v1/{project_id}/vpcs");
sig_str_t query_str = sig_str("limit=2");
sig_str_t payload = sig_str("");
params.host = host;
params.method = method;
params.uri = uri;
params.query_str = query_str;
params.payload = payload;

Step 4 Add header parameters or other headers required for other purposes. For example,
add the X-Project-Id header in multi-project scenarios or the X-Domain-Id
header for a global service.
//Add header parameters, for example, X-Domain-Id for invoking a global service and X-Project-Id for 
invoking a project-level service.
sig_headers_add(&params.headers, "X-Project-Id", "xxx");

Step 5 Execute the following function to add the generated headers as request variables.
sig_sign(&params);

Step 6 Use the curl library to access the API and view the access result.
static size_t
WriteMemoryCallback(void *contents, size_t size, size_t nmemb, void *userp)
{
    size_t realsize = size * nmemb;
    struct MemoryStruct *mem = (struct MemoryStruct *)userp;

    mem->memory = (char*)realloc(mem->memory, mem->size + realsize + 1);
    if (mem->memory == NULL) {
        /* out of memory! */
        printf("not enough memory (realloc returned NULL)\n");
        return 0;
    }

    memcpy(&(mem->memory[mem->size]), contents, realsize);
    mem->size += realsize;
    mem->memory[mem->size] = 0;

    return realsize;
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}

//send http request using curl library
int perform_request(RequestParams* request)
{
    CURL *curl;
    CURLcode res;
    struct MemoryStruct resp_header;
    resp_header.memory = malloc(1);
    resp_header.size = 0;
    struct MemoryStruct resp_body;
    resp_body.memory = malloc(1);
    resp_body.size = 0;

    curl_global_init(CURL_GLOBAL_ALL);
    curl = curl_easy_init();

    curl_easy_setopt(curl, CURLOPT_CUSTOMREQUEST, params.method.data);
    char url[1024];
    sig_snprintf(url, 1024, "http://%V%V?%V", &params.host, &params.uri, &params.query_str);
    curl_easy_setopt(curl, CURLOPT_URL, url);
    struct curl_slist *chunk = NULL;
    for (int i = 0; i < params.headers.len; i++) {
        char header[1024];
        sig_snprintf(header, 1024, "%V: %V", &params.headers.data[i].name, &params.headers.data[i].value);
        printf("%s\n", header);
        chunk = curl_slist_append(chunk, header);
    }
    printf("-------------\n");
    curl_easy_setopt(curl, CURLOPT_HTTPHEADER, chunk);
    curl_easy_setopt(curl, CURLOPT_POSTFIELDS, params.payload.data);
    curl_easy_setopt(curl, CURLOPT_NOBODY, 0L);
    curl_easy_setopt(curl, CURLOPT_WRITEFUNCTION, WriteMemoryCallback);
    curl_easy_setopt(curl, CURLOPT_HEADERDATA, (void *)&resp_header);
    curl_easy_setopt(curl, CURLOPT_WRITEDATA, (void *)&resp_body);
    //curl_easy_setopt(curl, CURLOPT_VERBOSE, 1L);
    res = curl_easy_perform(curl);
    if (res != CURLE_OK) {
        fprintf(stderr, "curl_easy_perform() failed: %s\n", curl_easy_strerror(res));
    }
    else {
        long status;
        curl_easy_getinfo(curl, CURLINFO_HTTP_CODE, &status);
        printf("status %d\n", status);
        printf(resp_header.memory);
        printf(resp_body.memory);
    }
    free(resp_header.memory);
    free(resp_body.memory);
    curl_easy_cleanup(curl);

    curl_global_cleanup();

    //free signature params
    sig_params_free(&params);
    return 0;
}

Step 7 Run the make command to obtain a main executable file, execute the file, and
then view the execution result.

----End

3.6.9 Android
This section uses Android Studio as an example to describe how to integrate the
Android SDK for API request signing. You can import the sample project in the
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code package, and integrate the signing SDK into your application by referring to
the API calling example.

Preparing the Environment
Download Android Studio at the Android Studio official website and install it.

Obtaining the SDK
Log in to the API Gateway console and choose Help Center > SDK Process Flow.
Then download the SDK. For details, see section "SDKs" in the User Guide.

The following table shows the directory structure of the downloaded package.

Name Description

app\ Android project code

build.gradle Gradle configuration files

gradle.properties

settings.gradle

 

Opening the Sample Project

Step 1 Start Android Studio and choose File > Open.

Select the directory where the SDK is decompressed.

Step 2 View the directory structure of the project shown in the following figure.
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----End

Request Signing and API Calling

Step 1 Add required JAR files to the app/libs directory of the Android project. The
following JAR files must be included:
● java-sdk-core-x.x.x.jar
● commons-logging-1.2.jar
● joda-time-2.9.9.jar

Step 2 Add dependencies of the okhttp library to the build.gradle file.

Add implementation 'com.squareup.okhttp3:okhttp:3.11.0' in the dependencies
field of the build.gradle file.
dependencies {    
    ...
    ...
    implementation 'com.squareup.okhttp3:okhttp:3.11.0'
}

Step 3 Create a request, enter the AK and SK, and specify the domain name, method,
request URI, and body.
Request request = new Request();
try {
        request.setKey("QTWAOYTT*******KYUC");
        request.setSecrect("MFyfvK41ba2giqM7**********KGpownRZlmVmHc");
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        request.setMethod("GET");
        request.setUrl("https://service.region.example.com3/v1/{project_id}/vpcs");
        request.addQueryStringParam("name", "value");
        request.addHeader("Content-Type", "text/plain");
        //request.setBody("demo");
} catch (Exception e) {
    e.printStackTrace();
    return;
}

Step 4 Sign the request to generate an okhttp3.Request object for API access.
okhttp3.Request signedRequest = Client.signOkhttp(request);
OkHttpClient client = new OkHttpClient.Builder().build();
Response response = client.newCall(signedRequest).execute();

----End
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4 Error Codes

If an error code starting with APIGW is displayed when you call an API, seek
solutions in the following table.

Table 4-1 Error codes

Error
Code

Error Message HTTP
Statu
s
Code

Description Corrective Action

APIGW.
0101

The API does not exist
or has not been
published in the
environment.

404 The API does
not exist or has
not been
published in
the
environment.

Rectify the fault
by following the
instructions in
What Should I
Do If "The API
does not exist or
has not been
published in the
environment." Is
Displayed?.

APIGW.
0101

The API does not
exist.

404 The request
method does
not exist.

Check whether
the request
method is the
same as the
method specified
for the API.

APIGW.
0103

The backend does not
exist.

404 The backend
service is not
found.

Contact technical
support.

APIGW.
0104

The plug-ins do not
exist.

400 No plugin
configurations
are found.

Contact technical
support.
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Error
Code

Error Message HTTP
Statu
s
Code

Description Corrective Action

APIGW.
0105

The backend
configurations do not
exist.

400 No backend
configurations
are found.

Contact technical
support.

APIGW.
0106

Orchestration error. 400 Orchestration
error.

Check whether
the frontend and
backend
parameters are
properly set for
the API.

APIGW.
0201

API request error. 400 Invalid request
parameters.

Set valid request
parameters.

APIGW.
0201

Request entity too
large.

413 The request
body exceeds
12 MB.

Reduce the size of
the request body.

APIGW.
0201

Request URI too large. 414 The request URI
is too large.

Reduce the size of
the request URI.

APIGW.
0201

Request headers too
large.

494 The request
headers are too
large.

Reduce the size of
the request
headers.

APIGW.
0201

Backend unavailable. 502 The backend
service is
currently
unavailable.

Check whether
the backend
address
configured for the
API is accessible.

APIGW.
0201

Backend timeout. 504 The backend
service timed
out.

Increase the
timeout duration
of the backend
service or shorten
the processing
time.

APIGW.
0301

Incorrect IAM
authentication
information.

401 The IAM
authentication
information is
incorrect.

Rectify the fault
by following the
instructions in
Common Errors
Related to IAM
Authentication
Information.

APIGW.
0302

The IAM user is not
authorized to access
the API.

403 The IAM user is
not allowed to
access the API.

Check whether
the user has been
blacklisted or
whitelisted.
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Error
Code

Error Message HTTP
Statu
s
Code

Description Corrective Action

APIGW.
0303

Incorrect app
authentication
information.

401 The app
authentication
information is
incorrect.

Check whether
the request
method, path,
query parameters,
and request body
are consistent
with those used
for signing. Check
whether the date
and time on the
client are correct.

APIGW.
0304

The app is not
authorized to access
the API.

403 The app is not
allowed to
access the API.

Check whether
the app has been
authorized to
access the API.

APIGW.
0305

Incorrect
authentication
information.

401 The
authentication
information is
incorrect.

Check whether
the authentication
information is
correct.

APIGW.
0306

API access denied. 403 Access to the
API is not
allowed.

Check whether
you have been
authorized to
access the API.

APIGW.
0307

The token must be
updated.

401 The token
needs to be
updated.

● Obtain a new
token from
IAM.

● An API of
another region
may have been
called. Check
the API URL.
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Error
Code

Error Message HTTP
Statu
s
Code

Description Corrective Action

APIGW.
0308

The throttling
threshold has been
reached.

429 The request
throttling
threshold is
reached.

● Try again after
the throttling
resumes. By
default, an API
can be
accessed a
maximum of
200 times per
second.

● The rate limits
of cloud
service APIs
cannot be
adjusted. Try
again after the
throttling
resumes.

● To adjust the
rate limit of an
API you have
created in API
Gateway,
contact
technical
support by
submitting a
service ticket.

APIGW.
0310

The project is
unavailable.

403 The project is
currently
unavailable.

Select another
project and try
again.

APIGW.
0311

Incorrect debugging
authentication
information.

401 The debugging
authentication
information is
incorrect.

Contact technical
support.

APIGW.
0401

Unknown client IP
address.

403 The client IP
address cannot
be identified.

Contact technical
support.

APIGW.
0402

The IP address is not
authorized to access
the API.

403 The IP address
is not allowed
to access the
API.

Check whether
the IP address has
been blacklisted
or whitelisted.
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Error
Code

Error Message HTTP
Statu
s
Code

Description Corrective Action

APIGW.
0404

Access to the backend
IP address has been
denied.

403 The backend IP
address cannot
be accessed.

The backend IP
address or the IP
address of the
backend domain
cannot be
accessed. Check
whether the IP
address exists or
has been
blacklisted or
whitelisted.

APIGW.
0501

The app quota has
been used up.

405 The app quota
has been
reached.

Increase the app
quota.

APIGW.
0502

The app has been
frozen.

405 The app has
been frozen.

Account balance
is insufficient. Go
to the Funds
Management
page to top up
your account.

APIGW.
0601

Internal server error. 500 Internal error. Contact technical
support.

APIGW.
0602

Bad request. 400 Invalid request. Check whether
the request is
valid.

APIGW.
0605

Domain name
resolution failed.

500 Domain name
resolution
failed.

Check whether
the domain name
is correct and has
been bound to a
correct backend
address.

APIGW.
0606

Failed to load the API
configurations.

500 API
configurations
are not loaded.

Contact technical
support.

APIGW.
0607

The following protocol
is supported: {xxx}

400 The protocol is
not supported.
Only xxx is
supported.
xxx indicates
the protocol in
a response.

Use HTTP or
HTTPS to access
the API.
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Error
Code

Error Message HTTP
Statu
s
Code

Description Corrective Action

APIGW.
0608

Failed to obtain the
admin token.

500 The tenant
account
information
cannot be
obtained.

Contact technical
support.

APIGW.
0609

The VPC backend does
not exist.

500 The VPC
backend service
cannot be
found.

Contact technical
support.

APIGW.
0610

No backend available. 502 No backend
services are
available.

Check whether all
backends are
available.

APIGW.
0611

The backend port
does not exist.

500 The backend
port is not
found.

Contact technical
support.

APIGW.
0612

An API cannot call
itself.

500 An API cannot
call itself.

Modify the
backend
configurations,
and ensure that
the number of
layers the API is
recursively called
does not exceed
10.

APIGW.
0613

The IAM service is
currently unavailable.

503 IAM is currently
unavailable.

Contact technical
support.

APIGW.
0705

Backend signature
calculation failed.

500 Backend
signature
calculation
failed.

Contact technical
support.

APIGW.
0801

The service is
unavailable in the
currently selected
region.

403 The service is
inaccessible in
the current
region.

Check whether
the service
supports cross-
region access.

APIGW.
0802

The IAM user is
forbidden in the
currently selected
region.

403 The IAM user is
not allowed to
access the
region.

Contact technical
support.
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5 FAQs

5.1 How Do I Call APIs in a Subproject?
To access resources in a subproject by calling APIs, add the X-Project-Id parameter
to the request header and set the parameter value to the subproject ID. For details
on how to add the X-Project-Id parameter, see Signing SDKs and Demo.

5.2 Does API Gateway Support Persistent Connections?
Yes. But you should use persistent connections properly to avoid occupying too
many resources.

5.3 Must the Request Body Be Signed?
No. If you do not want to sign the request body, add the following parameter and
value to the message header:

X-Sdk-Content-Sha256:UNSIGNED-PAYLOAD

UNSIGNED-PAYLOAD indicates the hashed position value calculated based on the
request body.

5.4 Are Request Header Parameters Required for
Signing Requests?

If you sign API requests by following the instructions in AK/SK Signing and
Authentication Algorithm, only X-Sdk-Date is required and other request header
parameters are optional.

If you use an SDK provided by Huawei Cloud to sign API requests, you do not need
to consider which request header parameters are required. The SDK determines
which parameters are required and automatically generates the signature
information. If the value of a request header parameter changes after requests are
signed, assign a value to the parameter again after signing.
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5.5 How Do I Use a Temporary AK/SK to Sign Requests?
Integrate the signing SDK into your application and add the following parameter
and value to the message header:

X-Security-Token:{securityToken}

Then, use a temporary AK/SK to sign the request. The signing SDK can be the SDK
used for AK/SK-based authentication.

Step 1 Create an API, set the authentication mode to IAM, and publish the API.

Step 2 Obtain a temporary AK/SK and {securityToken}. For details, see the Identity and
Access Management API Reference.

A response similar to the following is displayed:
{
    "credential": {
        "access": "P0HEQUQ4XBWXY5WD69X0",
        "expires_at": "2022-10-17T18:51:25.231000Z",
        "secret": "3WJuF1oMFSoSJSWKAWrhUVOVWvtAnATAbS61hDVs",
        "securitytoken": "XXXXXX......"
    }
}

Step 3 Construct a request with signature parameters.
...
request.setKey("P0HEQUQ4XBWXY5WD69X0");
request.setSecret("3WJuF1oMFSoSJSWKAWrhUVOVWvtAnATAbS61hDVs");
request.setMethod("GET");
request.setUrl("url");
request.addHeader("X-Security-Token", "XXXXXX......");
...

----End

5.6 Common Errors Related to IAM Authentication
Information

You may encounter the following errors related to IAM authentication
information:

● Incorrect IAM authentication information: verify aksk signature fail
● Incorrect IAM authentication information: AK access failed to reach the

limit, forbidden
● Incorrect IAM authentication information: decrypt token fail
● Incorrect IAM authentication information: Get secretKey failed

Incorrect IAM authentication information: verify aksk signature fail
{    
  "error_msg": "Incorrect IAM authentication information: verify aksk signature fail, ......   
  "error_code": "APIGW.0301", 
  "request_id": "******" 
}

Possible Cause
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The signature algorithm is incorrect, and the signature calculated by the client is
different from that calculated by API Gateway.

Solution

Step 1 Obtain the canonicalRequest calculated by APIG.

Obtain request_id from the body of the error message, search for error.log (you
can view this file on CLS) of the shubao node based on request_id, and obtain
canonicalRequest from error.log.
2019/01/26 11:34:27 [error] 1211#0: *76 [lua] responses.lua:170: rewrite(): 
473a4370fbaf69e42f9da243eb8f8c52;app-1;Incorrect IAM authentication information: verify signature 
fail;SDK-HMAC-SHA256 Access=071fe245-9cf6-4d75-822d-c29945a1e06a, SignedHeaders=host;x-sdk-date, 
Signature=b2ef2cddcef89cbfe22974c988909c1a94b1ac54114c30b8fe083d34a259e0f5;canonicalRequest:GE
T
/app1/

host:test.com
x-sdk-date:20190126T033427Z

host;x-sdk-date
e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855, client: 192.168.0.1, server: 
shubao, request: "GET /app1 HTTP/1.1", host: "test.com"

Step 2 Obtain the canonicalRequest calculated by the client by printing logs or using
debug interrupts. The following table describes the functions used to calculate the
canonicalRequest in the SDKs of different languages.

Table 5-1 Functions for calculating canonicalRequest in the SDKs of common
languages

Langua
ge

Function

Java Sign function in com.cloud.sdk.auth.signer.DefaultSigner.class of libs/
java-sdk-core-*.jar

C sig_sign function in signer.c

C++ Signer::createSignature function in signer.cpp.

C# Sign function in signer.cs

Go Sign function in signer.go

JavaScri
pt

Signer.prototype.Sign function in signer.js

Python Sign function in signer.py

PHP Sign function in signer.php

 

Example: cannonicalRequest obtained at a debug interrupt

POST 
/app1/  

host:test.com 
x-sdk-date:20190126T033950Z  
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host;x-sdk-date 
e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855

Step 3 Check whether the cannonicalRequest in Step 1 is the same as that in Step 2.
● Yes: Check whether the AK and SK are correct, for example, without spaces.
● No:

– Different in line 1: The request method must be the same.
– Different in line 2: The request path must be the same.
– Different in line 3: The request parameters must be the same.
– Different in lines 4 to 5: The request header must be the same in each

line.
– Different in line 7: The number of request header parameters must be the

same as the number of request header lines.
– Different in line 8: The request body must be the same.

Table 5-2 canonicalRequest of APIG and a client

Lin
e
No.

Parameter APIG Client

1 Request method GET POST

2 Request path /app1/ /app1/

3 Request
parameters

None None

4 Request header host:test.com host:test.com

5 Request header x-sdk-date:
20190126T033427Z

x-sdk-date:
20190126T033950Z

6 Blank line - -

7 Request header
parameters

host;x-sdk-date host;x-sdk-date

8 Request body
hash value

e3b0c44298fc1c149af
bf4c8996fb92427ae41
e4649b934ca495991b
7852b855

e3b0c44298fc1c149afbf4c89
96fb92427ae41e4649b934ca
495991b7852b855

 

----End

Incorrect IAM authentication information: AK access failed to reach the
limit, forbidden

{    
  "error_msg": "Incorrect IAM authentication information: AK access failed to reach the 
limit,forbidden." ......   
  "error_code": "APIGW.0301", 
  "request_id": "******" 
}
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Possible Causes

● The AK/SK signature calculation is incorrect. Resolve the problem by referring
to Incorrect IAM authentication information: verify aksk signature fail.

● The AK and SK do not match.
● AK/SK authentication fails for more than five consecutive times, and the

AK/SK pair is locked for five minutes. (Authentication requests are rejected
within this period).

● An expired token is used for token authentication.

Incorrect IAM authentication information: decrypt token fail
{
  "error_msg": "Incorrect IAM authentication information: decrypt token fail",
  "error_code": "APIGW.0301",
  "request_id": "******"
}

Possible Cause

The token cannot be parsed for IAM authentication of the API.

Solution

● Check whether the token is correct.
● Check whether the token has been obtained in the environment where the

API is called.

Incorrect IAM authentication information: Get secretKey failed
{
"error_msg": "Incorrect IAM authentication information: Get secretKey failed,ak:******,err:ak not exist",
"error_code": "APIGW.0301",
"request_id": "******"
}

Possible Cause

The AK used for IAM authentication of the API does not exist.

Solution

Check whether the AK is correct.

5.7 What Should I Do If "The API does not exist or has
not been published in the environment." Is Displayed?

If an open API in APIG failed to be called, troubleshoot the failure by performing
the following operations:

1. The domain name, request method, or path used for calling the API is
incorrect.
– For example, an API registered using the POST method is called with GET.
– Missing a slash (/) in the access URL will lead to a failure in matching the

URL in the API details. For example, URLs http://
7383ea59c0cd49a2b61d0fd1d351a619.apigw.region.cloud.com/test/
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and http://
7383ea59c0cd49a2b61d0fd1d351a619.apigw.region.cloud.com/test
represent two different APIs.

2. The API has not been published. APIs can be called only after they have been
published in an environment. For details, see section "Publishing an API" in
the User Guide. If the API has been published in a non-production
environment, check whether the X-Stage header in the request is the name of
the environment.

3. The domain name is resolved incorrectly. If the domain name, request
method, and path for calling the API are correct and the API has been
published in an environment, the API may not be correctly resolved to the
group to which the API belongs. For example, if you have multiple API groups
and each group has an independent domain name, the API may be called
using the independent domain name of another group. Ensure that the API is
being called using the correct domain name.

4. Check whether the API allows OPTIONS cross-region requests. If yes, enable
cross-origin resource sharing (CORS) for the API, and create a new API that
uses the OPTIONS method. For details, see section "CORS" in the User Guide.

API Request
Signing Guide 5 FAQs

Issue 01 (2022-09-08) Copyright © Huawei Technologies Co., Ltd. 55



A Change History

Table A-1 Change history

Date Description

2022-09-08 This issue is the first official release.
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