ALM-25500 KrbServer Service Unavailable (For MRS 2.x or Earlier)
Description
The system checks the KrbServer service status every 30 seconds. This alarm is generated when the KrbServer service is abnormal.
This alarm is cleared when the KrbServer service is in normal state.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
25500 |
Critical |
Yes |
Parameters
Parameter |
Description |
---|---|
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
When this alarm is generated, no operation can be performed for the KrbServer component in the cluster. The authentication of KrbServer in other components will be affected. The health status of components that depend on KrbServer in the cluster is Bad.
Possible Causes
- The node where the KrbServer service locates is faulty.
- The OLdap service is unavailable.
Procedure
- Check whether the node where the KrbServer service locates is faulty.
- Go to the MRS cluster details page and click Components.
- Choose KrbServer > Instances. Go to the KrbServer instance page and view the host name of the node where the KrbServer service is deployed.
- On the Alarms page of MRS Manager, check whether the alarm ALM-12006 Node Fault is generated.
- Check whether the host name in the alarm information is the same as the actual host name in 1.b.
- Rectify the fault by following steps provided in ALM-12006 Node Fault.
- In the alarm list, check whether the alarm ALM-25500 KrbServer Service Unavailable is cleared.
- If yes, no further action is required.
- If no, go to 3.
- Check whether the OLdap service is unavailable.
- Go to the cluster details page and choose Alarms.
- Check whether ALM-12004 OLdap Resource Is Abnormal is generated.
- Rectify the fault by following steps provided in ALM-12004 OLdap Resource Is Abnormal.
- In the alarm list, check whether the alarm ALM-25500 KrbServer Service Unavailable is cleared.
- If yes, no further action is required.
- If no, go to 3.
- Collect fault information.
- On MRS Manager, choose System > Export Log.
- Contact the O&M engineers and send the collected logs.
Reference
None
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