Why Can't Grafana Display Content?
Symptom
After the Prometheus add-on is installed on the CCE add-on page, Grafana cannot display monitoring data.
Possible Causes
Grafana parameters are incorrect.
Solution
- Log in to the CCE console (old version).
- In the navigation pane on the left, choose Resource Management > Network. On the Services tab page, obtain the access address and port number of the Grafana service and the access domain name and port number of the Prometheus service.
- In the navigation pane on the left, choose Configuration Center > ConfigMaps. On the displayed page, locate grafana-conf, click Edit YAML in the Operation column, and change root_url to the Grafana access address.
- On the ConfigMaps page, locate grafana-datasources, click Edit YAML in the Operation column, and change url to the Prometheus domain name.
- Restart the Grafana pod to view monitoring data.
Usage FAQs FAQs
- What Can I Do If I Do Not Have the Permission to Access SMN?
- What Can I Do If Resources Are Not Running Properly?
- How Do I Set the Full-Screen Online Duration?
- What Can I Do If the Log Usage Reaches 90% or Is Full?
- How Do I Obtain an AK/SK?
- How Can I Check Whether a Service Is Available?
- Why Is the Status of an Alarm Rule Displayed as "Insufficient"?
- Why the Status of a Workload that Runs Normally Is Displayed as "Abnormal" on the AOM Page?
- How Do I Create the apm_admin_trust Agency?
- How Do I Obtain the AK/SK by Creating an Agency?
- What Is the Billing Policy of Logs?
- Why Can't I See Any Logs on the Console?
- What Can I Do If an ICAgent Is Offline?
- Why Can't the Host Be Monitored After ICAgent Is Installed?
- Why Is "no crontab for root" Displayed During ICAgent Installation?
- Why Can't I Select an OBS Bucket When Configuring Log Dumping on AOM?
- Why Can't Grafana Display Content?
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.
more