
# GAUSS-52900 -- GAUSS-52999
GAUSS-52900 : " Failed to upgrade strategy: %s."
SQLSTATE:无
错误原因：升级策略失败。
解决办法：检查版本信息文件version.cfg。
GAUSS-52902 : "Can not support upgrade from %s to %s."
SQLSTATE:无
错误原因：不支持从该版本的升级。
解决办法：请使用支持的版本进行升级，或使用中间版本过渡。
GAUSS-52904 : "Please choose right upgrade strategy."
SQLSTATE:无
错误原因：请选择正确的升级策略。
解决办法：调用策略选择接口，正确使用升级接口，或调用自动升级接口。
GAUSS-52905 : "Failed to obtain old cluster version."
SQLSTATE:无
错误原因：获取当前版本号失败。
解决办法：请查看相应的日志，查找详细的错误信息。
GAUSS-52908 : "Failed to set cluster read-only mode."
SQLSTATE:无
错误原因：设置只读模式失败。
解决办法：查看guc日志，排除错误后，重新执行命令。
GAUSS-52909 : "Invalid mode: %s."
SQLSTATE:无
错误原因：不合法的模式。
解决办法：请查找相对应的日志信息。
GAUSS-52910 : "Failed to check user definition."
SQLSTATE:无
错误原因：用户自定义检查失败。
解决办法：排查用户自定义检查脚本是否存在错误，或根据检查期望，排查升级失败原因。
GAUSS-52911："Full upgrade failed. Roll back to the original cluster."
SQLSTATE:无
错误原因：完全升级失败
解决办法：重新升级
GAUSS-52912 : "Failed to start the new cluster in normal mode. Please manually handle the problem and start it again."
SQLSTATE:无
错误原因：在普通模式启动集群失败。
解决办法：手动排除原因，调用gs_om -t start命令手动启动集群。
GAUSS-52913："Can not do rollback."
SQLSTATE:无
错误原因：回滚失败
解决办法：重新执行。
GAUSS-52914 : "Failed to clean rollback script."
SQLSTATE:无
错误原因：清除回滚脚本失败。
解决办法：排查集群状态，若升级成功，可手动清理残留文件。
GAUSS-52915 : "Invalid upgrade step: %s."
SQLSTATE:无
错误原因：不合法的升级步骤。
解决办法：在GPHOST路径下，请确认升级备份的步骤记录文件是否被修改。
GAUSS-52916 : "The current environment does not meet upgrade requirements or fails to perform backup operations."
SQLSTATE:无
错误原因：环境不符合升级要求，或者备份失败。
解决办法：查看磁盘大小，确认足够的预留空间(不能小于200M)。
GAUSS-52917 : "Binary upgrade failed. Roll back to the original cluster."
SQLSTATE:无
错误原因：二进制升级失败，回滚到原始集群
解决办法：查看升级日志，排除错误原因后，重试
GAUSS-52918 : "Cannot find GTM in current cluster."
SQLSTATE:无
错误原因：没有找到GTM
解决办法：调用gs_om -t status --detail命令查询集群状态，确认GTM状态，如果集群中GTM状态异常，则需要重新安装集群方法修复该集群。
GAUSS-52919 : "Failed to upgrade."
SQLSTATE:无
错误原因：升级失败
解决办法：请查看升级日志，排除错误原因，根据实际情况重试。
GAUSS-52920 : "Failed to restore GUC parameter after full upgrade."
SQLSTATE:无
错误原因：全面升级后还原GUC参数失败
解决办法：请查看升级日志和GUC日志，排除原因，重新升级。
GAUSS-52921 : "Invalid upgrade type: %s."
SQLSTATE:无
错误原因：不合法的升级类型
解决办法：请使用自动升级接口。
GAUSS-52922 : "Failed to record step information on local node."
SQLSTATE:无
错误原因：记录升级步骤失败
解决办法：请确认临时文件目录的权限或是否存在。
GAUSS-52923 : "Failed to record upgrade status."
SQLSTATE:无
错误原因：记录升级状态失败
解决办法：请确认临时文件目录的权限或是否存在。
GAUSS-52924 : "The information in upgrade status file is wrong."
SQLSTATE:无
错误原因：升级状态文件中信息错误
解决办法：请确认是否修改升级备份文件，并尝试根据升级步骤恢复记录文件。
GAUSS-52925 : "Input upgrade type: %s record upgrade type: %s\\nMaybe you chose the wrong interface."
SQLSTATE:无
错误原因：使用不正确的升级接口
解决办法：请使用自动升级接口或者自动回滚接口。
GAUSS-52926 : "The step of upgrade should be digit."
SQLSTATE:无
错误原因：升级步骤必须是一个数字。
解决办法：请确认升级备份文件是否被修改，并尝试恢复。
GAUSS-52927 : "Failed to upgrade application."
SQLSTATE:无
错误原因：升级失败，安装新集群失败。
解决办法：请查看local日志，排除问题后重试。
GAUSS-52928 : "The version number of old cluster is \[%s\]. It must be a digit and greater than or equal to 1.0."
SQLSTATE:无
错误原因：旧集群版本号有误，应为数字，且大于或等于1.0。
解决办法：请查看当前集群的版本文件，确认是否被修改。
GAUSS-52929 : "Failed to check application version. Output: \\n%s."
SQLSTATE:无
错误原因：检查集群版本失败。
解决办法：请检查升级日志，确认各节点版本信息。
GAUSS-52930 : "Failed to check upgrade environment."
SQLSTATE:无
错误原因：检查升级环境失败。
解决办法：请检查local日志，确认环境问题，排除后，重新升级。
GAUSS-52931："Failed to check tablespace location path."
SQLSTATE:无
错误原因：检查tablespace本地路径失败
解决办法：去除tablespace路径中的"\\n"
