
# GAUSS-52800 -- GAUSS-52899
GAUSS-52800 : "Cluster is %s(%s) now."
SQLSTATE: 无
错误原因：集群状态不正常(集群状态为Abnormal或者Degrade)。
解决办法：查看集群状态根据日志报错分析原因。
GAUSS-52801 : "Only allow to %s one CN. The %s is not matched."
SQLSTATE: 无
错误原因：仅允许增加/删除一个CN，CN/DN/GTM/CM Server数量不匹配 。
解决办法：检查xml中配置是否对其它实例进行了增删操作。
GAUSS-52802 : "Only allow to add one CN at the end."
SQLSTATE: 无
错误原因：只允许在末尾增加一个CN 。
解决办法：请检查指定的XML配置，集群外增加CN只允许在集群中所有节点末尾增加一个CN。
GAUSS-52803 : "There is at least one Normal CN after delete CN."
SQLSTATE: 无
错误原因：在删除CN后至少要保留一个正常的CN。
解决办法：检查执行删除CN操作的XML文件配置是否正确，保证在做删除CN以后，集群中还有一个正常的CN。
GAUSS-52805 : "Failed to find another instance as model for instance(%s)."
SQLSTATE: 无
错误原因：没有找到其他可用的实例模板。
解决办法：查看具体日志分析失败原因。
GAUSS-52807 : "There is no IP changed."
SQLSTATE: 无
错误原因：没有需要修改的IP。
解决办法：检查IP是否已在集群中使用，如果在使用，则需要重新配置XML文件。
GAUSS-52808 : "Detected CN %s, but the action is %s."
SQLSTATE: 无
错误原因：命令中的增删CN操作和xml配置不一致。
解决办法：修改命令中的增删CN动作(add或者delete)或者修改xml中增删CN的配置信息。
GAUSS-52809 : "Only allow to add or delete one CN."
SQLSTATE: 无
错误原因：增删CN数量不为1。
解决办法：一次只允许增加或者删除一个CN。
GAUSS-52810："There is Abnormal coordinator(s) in cluster, please delete it firstly."
SQLSTATE：无
错误原因：集群中存在异常CN实例，导致想要删除的CN无法删除。
解决办法：先删除异常的CN，再进行其他CN的删除操作。
