
# GAUSS-04631 -- GAUSS-04640
GAUSS-04631: "cannot alter text search configuration '%s' because other objects depend on it"
SQLSTATE: 2BP01
错误原因：由于全文检索配置项与其他表或索引之间存在依赖关系，本配置信息不能更改。
解决办法：取消依赖关系后再执行本操作。
GAUSS-04632: "DFS table does not support index."
SQLSTATE: 0A000
错误原因：DFS类型的表不支持索引。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-04633: "It is not supported to create index '%s' on DFS tablespace."
SQLSTATE: 0A000
错误原因：不能在DFS类型的表空间中创建索引。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-04634: "It is not allowed to assign version option for non-dfs table."
SQLSTATE: XX000
错误原因：创建行存表或者CU格式的列存表时指定了version参数直接报错。
解决办法：创建行存表或者CU格式的列存表时不要version参数。
GAUSS-04636: "Invalid string for 'VERSION' option"
SQLSTATE: XX000
错误原因：无效的version参数。
解决办法：参数只支持0.12。
GAUSS-04637: "Num of partition keys in value-partitioned table should not be zero"
SQLSTATE: XX000
错误原因：创建valuesHDFS分区表时，没有指定分区列。
解决办法：创建valuesHDFS分区表时，指定不少于1，但是不超过4的列数。
GAUSS-04638: "Num of partition keys in value-partitioned table exceeds max allowed num:%d"
SQLSTATE: XX000
错误原因：创建valuesHDFS分区表时，指定分区列超过四个。
解决办法：创建valuesHDFS分区表时，指定不少于1，但是不超过4的列数。
GAUSS-04639: "Unsupported partition strategy '%s' feature for dfs table."
SQLSTATE: XX000
错误原因：仅支持value HDFS分区表，其余分区不支持，直接报错。
解决办法：创建分区HDFS表时，指定为value分区。
GAUSS-04640: "Only support hash distribution for dfs table."
SQLSTATE: XX000
错误原因：对于DFS表，只支持HASH分布。
解决办法：创建HDFS表只能指定成hash分布。
