
# GAUSS-04491 -- GAUSS-04500
GAUSS-04491: "could not find resource pool 'respool' in global hash table."
SQLSTATE: XX000
错误原因：内部不能正常创建resource pool 'respool'。
解决办法：内存不足导致的创建失败，需要中止其他不需要运行的事务，释放内存。
GAUSS-04492: "redundant options."
SQLSTATE: XX000
错误原因：冗余的选项。
解决办法：检查DDL语句中的选项是否有重复。
GAUSS-04493: "active_statements value can't be %ld."
SQLSTATE: 22003
错误原因：active_statements 值无效。
解决办法：设置active_statements的值必须大于等于-1。
GAUSS-04494: "max_dop value can't be %ld."
SQLSTATE: 22003
错误原因：max_dop的值无效。
解决办法：设置max_dop的值必须大于等于1。
GAUSS-04495: "invalid value '%s' for parameter 'memory_limit'"
SQLSTATE: 22023
错误原因：memory_limit的值格式无效。
解决办法：使用正确的内存大小格式，单位使用KB，MB，GB，数值要求整数。
GAUSS-04496: "memory_limit size value can't be %d."
SQLSTATE: 22003
错误原因：memory_limit的数值无效。
解决办法：memory_limit的数值必须是正数。
GAUSS-04497: "memory_limit size value must be less than max_process_memory(8GB)."
SQLSTATE: 22003
错误原因：memory_limit的数值在设置和修改时不能超过max_process_memory。
解决办法：检查memory_limit的数值，不要超过max_process_memory。
GAUSS-04498: "cache lookup failed for resource pool id %u, user is removed?"
SQLSTATE: XX000
错误原因：resource pool不存在。
解决办法：检查用户或者resource pool是否已经被移除。
GAUSS-04499: "Failed to Generate the random salt"
SQLSTATE: 28000
错误原因：系统内部错误。生成随机盐值失败。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-04500: "Failed to Generate the random serverkey"
SQLSTATE: 28000
错误原因：系统内部错误。获取随机的serverkey失败。
解决办法：请联系技术支持工程师提供技术支持。
