
# GAUSS-04461 -- GAUSS-04470
GAUSS-04461: "The number of HDFS NameNode must be less than or equal to 2."
SQLSTATE: XX000
错误原因：配置文件中配置HDFS的NameNode节点个数多于两个。
解决办法：检查配置文件hdfs-site.xml中dfs.ha.namenodes.hacluster是否配置多于两个NameNode。
GAUSS-04462: "Failed to get address from config file."
SQLSTATE: XX000
错误原因：配置文件中没有配置HDFS的NameNode的地址。
解决办法：配置文件hdfs-site.xml中dfs.namenode.rpc-address.hacluster项，填写正确的HDFS NameNode的地址。
GAUSS-04464: "invalid User, user is null"
SQLSTATE: XX000
错误原因：系统内部错误。获取HDFSUser为空。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-04465: "invalid cfgPath which can not be null on security mode."
SQLSTATE: XX000
错误原因：系统内部错误。获取HDFS配置文件的路径信息失败。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-04466: "invalid connection information"
SQLSTATE: XX000
错误原因：系统内部错误。获取连接HDFS的相关信息失败。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-04467: "failed to do an authentication for hdfs server"
SQLSTATE: XX000
错误原因：系统内部错误。连接HDFS的安全认证失败。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-04468: "corrupt during reset shared hash table '%s'"
SQLSTATE: XX000
错误原因：重置共享hash表过程中内存崩溃。
解决办法：节点重启，无需额外处理。
GAUSS-04469: "terminating SyncLocalXactsWithGTM process due to administrator command"
SQLSTATE: 57P01
错误原因：主降备或者系统退出过程中SyncLocalXactsWithGTM被停止。
解决办法：无需额外处理。
GAUSS-04470: "sorry, too many clients already, active/non-active: %d/%d."
SQLSTATE: 53300
错误原因：数据库连接数过多。
解决办法：关闭non-active状态的连接，然后重新建立连接。
