
# GAUSS-03571 -- GAUSS-03580
GAUSS-03571: "WAL level not sufficient for making an online backup"
SQLSTATE: 55000
错误原因：配置WAL级别不足。
解决办法：配置WAL级别为archive或hot_standby，重启数据库后执行备份操作。
GAUSS-03572: "backup label too long (max %d bytes)"
SQLSTATE: 22023
错误原因：备份路径名称超过限制。
解决办法：修改配置路径名称，重新执行备份操作。
GAUSS-03573: "a backup is already in progress"
SQLSTATE: 55000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-03574: "WAL generated with full_page_writes=off was replayed since last restartpoint"
SQLSTATE: 55000
错误原因：配置项full_page_writes为off。
解决办法：配置full_page_writes为on，在主机做CHECKPOINT后，再次执行备份。
GAUSS-03575: "could not write file '%s': %m"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-03576: "a backup is not in progress"
SQLSTATE: 55000
错误原因：没有任何正在执行的备份供停止。
解决办法：SELECT pg_start_backup和SELECT pg_stop_backup是成对出现的。必须先执行了开始备份，才能执行关闭备份。请确认相关备份是否已开启。
GAUSS-03577: "invalid data in file '%s'"
SQLSTATE: 55000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-03578: "the standby was promoted during online backup"
SQLSTATE: 55000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-03579: "WAL generated with full_page_writes=off was replayed during online backup"
SQLSTATE: 55000
错误原因：配置项full_page_writes为off。
解决办法：请配置full_page_writes为on，在主机做CHECKPOINT后，再次执行备份。
GAUSS-03580: "invalid record offset at %X/%X."
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
