
# GAUSS-03411 -- GAUSS-03420
GAUSS-03411: "scan in progress on supposedly new bucket"
SQLSTATE: XX000
错误原因：在新的bucket上有scan操作。
解决办法：等scan操作结束后，再尝试执行本操作。
GAUSS-03412: "could not get lock on supposedly new bucket"
SQLSTATE: XX000
错误原因：新bucket上的锁被占用。
解决办法：尝试再次执行。
GAUSS-03413: "invalid overflow block number %u"
SQLSTATE: XX000
错误原因：超过hash表的内部最大页号。
解决办法：内部错误，属于预防性报错机制。请联系技术支持工程师提供技术支持。
GAUSS-03414: "firstfreebit found no free bit"
SQLSTATE: XX000
错误原因：没有找到free bit。
解决办法：内部错误，属于预防性报错机制。请联系技术支持工程师提供技术支持。
GAUSS-03415: "invalid overflow bit number %u"
SQLSTATE: XX000
错误原因：超过最大bitmap页数。
解决办法：内部错误，属于预防性报错机制。请联系技术支持工程师提供技术支持。
GAUSS-03416: "out of overflow pages in hash index '%s'"
SQLSTATE: 54000
错误原因：hash索引支持容量达到上限。
解决办法：请重建索引。
GAUSS-03417: "missing support function %d(%u,%u) for index '%s'"
SQLSTATE: XX000
错误原因：不支持该哈希函数。
解决办法：使用其他的哈希函数。
GAUSS-03418: "index '%s' contains unexpected zero page at block %u"
SQLSTATE: XX002
错误原因：索引检测到空页。
解决办法：请重建索引。
GAUSS-03419: "index '%s' contains corrupted page at block %u"
SQLSTATE: XX002
错误原因：索引检测到坏页。
解决办法：请重建索引。
GAUSS-03420: "index '%s' is not a hash index"
SQLSTATE: XX002
错误原因：该索引不属于哈希索引。
解决办法：内部错误，属于预防性报错机制。请联系技术支持工程师提供技术支持。
