
# GAUSS-03391 -- GAUSS-03400
GAUSS-03392: "must be system admin or have the same role to cancel queries running in other server processes"
SQLSTATE: 42501
错误原因：用户没有权限取消查询。
解决办法：要取消运行在其它服务器进程中的查询，用户必须是相同管理员或相同角色。
GAUSS-03393: "this is a test."
SQLSTATE: XX000
错误原因：测试代码，不需要暴露给用户。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-03394: "must be system admin or have the same role to terminate other backend"
SQLSTATE: 42501
错误原因：用户没有权限终止其它后台进程。
解决办法：要终止运行在其它服务器进程中的查询，用户必须是相同管理员或相同角色。
GAUSS-03395: "must be system admin to signal the postmaster"
SQLSTATE: 42501
错误原因：重新装载数据库配置参数需要具有系统管理员权限。
解决办法：切换为系统管理员后，重新装载数据库配置参数。
GAUSS-03396: "must be system admin to rotate log files"
SQLSTATE: 42501
错误原因：只有系统管理员才能轮换日志文件。
解决办法：先获取系统管理员权限，再执行日志文件轮换。
GAUSS-03397: "fail to drop the user"
SQLSTATE: 42501
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-03398: "index '%s' already contains data"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-03399: "failed to re-find scan position within index '%s'"
SQLSTATE: XX000
错误原因：偏移量大于内部最大偏移量。
解决办法：属于预防性错误机制。请联系技术支持工程师提供技术支持。
GAUSS-03400: "hash does not support mark/restore"
SQLSTATE: XX000
错误原因：哈希不支持记录或者恢复scan position。
解决办法：属于功能不支持，请检查使用方式。
