
# GAUSS-03301 -- GAUSS-03310
GAUSS-03301: "cannot lock cluster for backup in presence of %d uncommitted prepared transactions"
SQLSTATE: 55P03
错误原因：存在未提交的prepared transaction时无法锁定集群进行备份。
解决办法：等待prepared transaction提交后，再锁定集群进行备份。
GAUSS-03302: "cannot lock cluster for backup, lock is already held"
SQLSTATE: 55P03
错误原因：未获取到锁，无法锁定集群进行备份。
解决办法：等待其它持锁作业完成后，再进行此项操作。
GAUSS-03303: "cannot execute %s in a locked cluster"
SQLSTATE: 25006
错误原因：集群已被他人锁定，无法执行命令。
解决办法：等待其它持锁作业完成后，再进行此项操作。
GAUSS-03304: "word is too long (%ld bytes, max %ld bytes)"
SQLSTATE: 54000
错误原因：单词太长，超过允许的最大值。
解决办法：使用不超过长度限制的单词。
GAUSS-03305: "string is too long for tsvector (%ld bytes, max %ld bytes)"
SQLSTATE: 54000
错误原因：字符串太长，超过允许的最大长度。
解决办法：使用不超过长度限制的字符串。
GAUSS-03306: "positions array too long"
SQLSTATE: XX000
错误原因：输入的字符串长度超过了tsvector类型允许的最大长度( (1\<\<20) - 1)。
解决办法：调整输入的字符串长度。
GAUSS-03307: "invalid size of tsvector"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-03308: "invalid tsvector: lexeme too long"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-03309: "invalid tsvector: maximum total lexeme length exceeded"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-03310: "unexpected number of tsvector positions"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
