
# GAUSS-02151 -- GAUSS-02160
GAUSS-02151: "PGXC Node %s: object already defined"
SQLSTATE: 42710
错误原因：对象已定义，指定的node name对应的节点已创建。
解决办法：修改指定的node name。
GAUSS-02152: "Node name '%s' is too long"
SQLSTATE: 42P17
错误原因：指定的node name过长。
解决办法：修改指定的node name。
GAUSS-02153: "Failed to create coordinator, the maximum number of coordinators %d specified by 'max_coordinators' has been reached."
SQLSTATE: 42601
错误原因：语法错误，创建的coordinator数量超过设置的max_coordinators数量。
解决办法：调大max_coordinators配置参数。
GAUSS-02154: "Failed to create datanode, the maximum number of datanodes %d specified by 'max_datanodes' has been reached."
SQLSTATE: 42601
错误原因：语法错误，创建的DN数量超过设置的max_datanodes数量。
解决办法：调大max_datanodes配置参数。
GAUSS-02155: "PGXC node %s: two nodes cannot be primary"
SQLSTATE: 42601
错误原因：语法错误，已经创建了一个primary node。
解决办法：根据需要将之前创建的primary node改为非primary节点。
GAUSS-02156: "must be system admin to change cluster nodes"
SQLSTATE: 42501
错误原因：权限不足，执行alter node语句需要系统管理员权限。
解决办法：使用系统管理员权限执行。
GAUSS-02157: "cache lookup failed for object %u"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-02158: "PGXC node %s: cannot alter Coordinator to Datanode"
SQLSTATE: 42601
错误原因：语法错误，无法将CN改为DN。
解决办法：禁止将CN修改为DN。
GAUSS-02159: "PGXC node %s: cannot alter Datanode to Coordinator"
SQLSTATE: 42601
错误原因：语法错误，无法将DN改为CN。
解决办法：禁止将DN修改为CN。
GAUSS-02160: "must be system admin to remove cluster nodes"
SQLSTATE: 42501
错误原因：权限不足，执行drop node语句需要系统管理员权限。
解决办法：使用系统管理员权限执行。
