
# GAUSS-02061 -- GAUSS-02070
GAUSS-02061: "could not send data to WAL stream: %s"
SQLSTATE: XX000
错误原因：主备日志复制过程中，备机发送数据时检测到错误。根据""%s""给出的主备连接返回的错误信息进行处理。
解决办法：1. 网络连接超时异常/当前主机业务压力大，调整当前网络环境/调整业务压力。2. 主机异常关闭，检查主机异常关闭原因。
GAUSS-02062: "sockaddr is NULL, because there is no connection to primary"
SQLSTATE: XX000
错误原因：当前主备连接的socketaddr为空。主备连接出现异常。
解决办法：检查主备机日志，确认socket异常关闭的原因。
GAUSS-02063: "cannot continue Data streaming, recovery has already ended"
SQLSTATE: XX000
错误原因：当前实例已经退出恢复，不需要再继续启动数据复制。
解决办法：1. 当前属于正常报错。2. 检查备实例升主时机是否合适。
GAUSS-02064: "writing incorrect data page checksum at: rnode\[%u,%u,%u\], blocknum\[%u\], pageoffset\[%u\], size\[%u\], queueoffset\[%u/%u\]"
SQLSTATE: XX000
错误原因：备机收到主机发送的数据页CRC校验不通过。
解决办法：检查网络环境，确定当前是否存在丢包现象。
GAUSS-02065: "invalid tablespace link %s: %m"
SQLSTATE: XX000
错误原因：备机pg_tblspc目录下存在无效的符号链接。
解决办法：根据检查错误，确认是否为恶意操作。如果为恶意操作，请恢复环境，或联系技术支持工程师对故障备机进行重建修复。
GAUSS-02066: "invalid tablespace directory %s: %m"
SQLSTATE: 42809
错误原因：备机pg_tblspc目录下连接指向无效的目录。
解决办法：根据检查错误，确认是否为恶意操作。如果为恶意操作，请恢复环境，或联系技术支持工程师对故障备机进行重建修复。
GAUSS-02067: "'database %u/%u' invalid directory : %m"
SQLSTATE: XX000
错误原因：当前的数据目录不正确，为无效目录。
解决办法：根据检查错误，确认是否为恶意操作。如果为恶意操作，请恢复环境，或联系技术支持工程师对故障备机进行重建修复。
GAUSS-02068: "'database %u/%u' exists but is not a directory"
SQLSTATE: 42809
错误原因：备机的pg_tblspc目录中指向的表空间目录为非目录文件。
解决办法：根据检查错误，确认是否为恶意操作。如果为恶意操作，请恢复环境，或联系技术支持工程师对故障备机进行重建修复。
GAUSS-02069: "could not find type OID for relation %u"
SQLSTATE: XX000
错误原因：查找对应的relation失败。
解决办法：系统表异常，请联系技术支持工程师提供技术支持。
GAUSS-02070: "unrecognized list node type: %d"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
