
# GAUSS-02031 -- GAUSS-02040
GAUSS-02031: "must be system admin or replication role to use replication slots"
SQLSTATE: 42501
错误原因：必须是系统管理员或者replication角色才能使用创建或删除replication slots。
解决办法：确认当前的操作角色，理论上不允许自行删除/修改replication slot。
GAUSS-02032: "syntax error: unexpected character '%s'"
SQLSTATE: 42601
错误原因：语法错误，不能识别的符号。
解决办法：根据报错的信息，请联系技术支持工程师提供技术支持。
GAUSS-02033: "all replication slots are in use"
SQLSTATE: 53400
错误原因：当前所有已经配置的replication slot都在被使用。
解决办法：调整实例目录下postgresql.conf中的max_replication_slots参数。
GAUSS-02034: "replication slot '%s' does not exist"
SQLSTATE: 42704
错误原因：replication slot不存在。
解决办法：如果需要使用replication slot，先进行创建。
GAUSS-02035: "replication slot '%s' is already active"
SQLSTATE: 55006
错误原因：replication slot已经激活。
解决办法：检查激活当前的slot为active的对象是否合法。
GAUSS-02036: "could not rename '%s' to '%s': %m"
SQLSTATE: XX000
错误原因：无法重命名实例的slot目录。
解决办法：检查具体的错误码，进行处理。
GAUSS-02037: "replication slots can only be used if max_replication_slots \> 0"
SQLSTATE: 55000
错误原因：replication slots只有在max_replication_slots参数配置时才能使用。
解决办法：调整实例目录下postgresql.conf中的max_replication_slots参数。
GAUSS-02038: "replication slots can only be used if wal_level \>= archive"
SQLSTATE: 55000
错误原因：replication slots只有在wal_level参数配置至少为archive时才能使用。
解决办法：调整实例目录下postgresql.conf中的wal_level为archive或hot_standby。
GAUSS-02039: "could not rename file '%s' to '%s': %m"
SQLSTATE: XX000
错误原因：无法重命名文件。
解决办法：检查具体的错误码，进行处理。
GAUSS-02040: "could not unlink file '%s': %m"
SQLSTATE: XX000
错误原因：无法删除文件。
解决办法：检查具体的错误码，进行处理。
