
# GAUSS-02001 -- GAUSS-02010
GAUSS-02001: "could not fdatasync data file num %d, fd %d: %m"
SQLSTATE: XX000
错误原因：无法sync文件到磁盘，根据%m报错信息确定具体原因。
解决办法：根据报错信息，确定是否为磁盘只读或者为磁盘空间满，根据具体的原因进行修复。
GAUSS-02002: "received incorrect data page checksum at: rnode\[%u,%u,%u\], blocknum\[%u\], segno\[%u\], pageoffset\[%u\], size\[%u\], queueoffset\[%u/%u\]"
SQLSTATE: XX000
错误原因：备机收到主机发送的数据页CRC校验不通过。
解决办法：检查网络环境，确定当前是否存在丢包现象。
GAUSS-02004: "could not receive the ongoing mode information from the primary server: %s"
SQLSTATE: XX000
错误原因：备机接收不到主机的运行模式信息。
解决办法：1. 网络连接超时异常/当前主机业务压力大，调整当前网络环境/调整业务压力。2. 主机异常关闭，检查主机异常关闭原因。
GAUSS-02005: "invalid response from primary server"
SQLSTATE: XX000
错误原因：备机收到主机发送的系统标识消息长度错误。
解决办法：检查网络环境，确定当前是否存在丢包现象。
GAUSS-02006: "the mode of the remote server must be primary, current is %d"
SQLSTATE: XX000
错误原因：主机当前状态不是处于Primary。
解决办法：通过gs_om -t status --detail命令查询当前一对主备的连接信息，确认与postgresql.conf配置文件中replconninfo1以及replconninfo2字段配置匹配。
GAUSS-02007: "could not receive database system identifier and timeline ID from the primary server: %s"
SQLSTATE: XX000
错误原因：备机向主机进行system校验，主机返回失败。根据""%s""给出的主备连接返回的错误信息进行处理。
解决办法：1. 网络连接超时异常/当前主机业务压力大，调整当前网络环境/调整业务压力。2. 主机异常关闭，检查主机异常关闭原因。
GAUSS-02008: "database system identifier differs between the primary and standby"
SQLSTATE: XX000
错误原因："备机向主机进行system校验，主机和备机的唯一标识system ID不同。初步判断为主备第一次建立连接。"
解决办法：需要重建备机，集群环境下CM会在此情况下自动重建备机。
GAUSS-02009: "timeline %u of the primary does not match recovery target timeline %u"
SQLSTATE: XX000
错误原因："备机向主机进行system校验，主机和备机的当前时间线不同。初步判断为主机发生过备份恢复并切换时间线。"
解决办法：需要重建备机，集群环境下CM会在此情况下自动重建备机。
GAUSS-02010: "could not start DATA streaming: %s"
SQLSTATE: XX000
错误原因：备机向主机请求开启数据复制失败。根据""%s""给出的主备连接返回的错误信息进行处理。
解决办法：1. 网络连接超时异常/当前主机业务压力大，调整当前网络环境/调整业务压力。2. 主机异常关闭，检查主机异常关闭原因。
