
# GAUSS-01971 -- GAUSS-01980 错误码
GAUSS-01971: "could not stat control file '%s': %m"
SQLSTATE: XX000
错误原因：程序运行过程中需要访问的文件不存在。
解决办法：手动创建该文件或重新初始化数据目录。
GAUSS-01972: "duplicate option '%s'"
SQLSTATE: 42601
错误原因：服务端收的重建命令参数有重复。
解决办法：需要开发人员根据提示排查客户端命令参数。
GAUSS-01973: "could not stat file or directory '%s': %m"
SQLSTATE: XX000
错误原因：程序运行过程中需要访问的文件或目录不存在。
解决办法：手动创建该文件目录，或重新初始化数据目录。
GAUSS-01974: "Postmaster exited, aborting active base backup"
SQLSTATE: XX000
错误原因：子线程处理重建命令过程中，主线程退出。
解决办法：重新启动。
GAUSS-01975: "shutdown requested, aborting active base backup"
SQLSTATE: XX000
错误原因：子线程处理重建命令过程中，收到主线程的退出信号。
解决办法：重新启动。
GAUSS-01976: "server run mode changed, aborting active base backup"
SQLSTATE: XX000
错误原因：处理重建命令过程中，主机状态发生变化。
解决办法：以主机模式重新启动。
GAUSS-01977: "could not open file '%s': %m"
SQLSTATE: XX000
错误原因：打开某个文件失败，可能原因是文件不存在，权限不对，或文件损坏。
解决办法：可根据错误信息分析具体原因，如果文件不存在，需要创建对应文件；权限不对则修改权限；文件损坏则修复文件系统或磁盘。
GAUSS-01978: "archive member '%s' too large for tar format"
SQLSTATE: XX000
错误原因：处理重建命令过程中，主机需要发送的文件太大，无法压缩。
解决办法：如果文件合法，则需要分割压缩。
GAUSS-01979: "base backup could not send data, aborting backup"
SQLSTATE: XX000
错误原因：处理重建命令过程中，主备之间连接中断，发送文件失败。
解决办法：恢复主备机节点间的网络。
GAUSS-01980: "could not close log file %u, segment %u: %m"
SQLSTATE: XX000
错误原因：关闭某个文件失败，可能原因是文件损坏。
解决办法：可根据错误信息分析具体原因，如果文件损坏则修复文件系统或磁盘。
