
# GAUSS-01791 -- GAUSS-01800 错误码
GAUSS-01791: "collation '%s' for encoding '%s' already exists"
SQLSTATE: 42710
错误原因：对应于pg_encoding_to_char(collencoding)这种编码方式的字符集已经存在，因此无法创建。
解决办法：确认当前编码方式所对应的字符集空间。
GAUSS-01792: "collation '%s' already exists"
SQLSTATE: 42710
错误原因：想要创建的字符集已经存在，不可重复创建。
解决办法：确认当前数据库中已经存在的字符集。
GAUSS-01793: "could not find tuple for collation %u"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-01794: "multiple pg_shdepend entries for object %u/%u/%d deptype %c"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-01795: "cannot drop %s because it is required by the database system"
SQLSTATE: 2BP01
错误原因：由于当前数据库系统的某些对象依赖于提示中的对象，因此无法丢弃当前对象。
解决办法：请确认当前对象与其他对象之间的依赖性，或者想删除该对象时可增加"cascade"选项。
GAUSS-01796: "role %u was concurrently dropped"
SQLSTATE: 42704
错误原因：在记录表的依赖关系时，需要锁住该对象，但是拿到锁后，发现该表已不存在，报错。
解决办法：检查日志当中该表何时被丢弃并检查操作的逻辑合理性。
GAUSS-01797: "tablespace %u was concurrently dropped"
SQLSTATE: 42704
错误原因：在记录表空间的依赖关系时，需要锁住该对象，但是拿到锁后，发现该表空间已不存在，报错。
解决办法：检查日志当中该表空间何时被丢弃并检查操作的逻辑合理性。
GAUSS-01798: "database %u was concurrently dropped"
SQLSTATE: 42704
错误原因：在记录数据库的依赖关系时，需要锁住该对象，但是拿到锁后，发现该数据库已不存在，报错。
解决办法：检查日志当中该数据库何时被丢弃并检查操作的逻辑合理性。
GAUSS-01799: "unrecognized shared classId: %u"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-01800: "unrecognized dependency type: %d"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
