
# GAUSS-01761 -- GAUSS-01770 错误码
GAUSS-01761: "column name must be qualified"
SQLSTATE: 42601
错误原因：在对象中属性名称必须是已知被描述的。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-01762: "must be owner of large object %u"
SQLSTATE: 42501
错误原因：执行用户不是大对象的所有者。
解决办法：检查此大对象的用户权限，是否为大对象的所有者。
GAUSS-01763: "must be system admin"
SQLSTATE: 42501
错误原因：该对象被初始用户所拥有，但是该对象的持有者却并非被初始用户所拥有。
解决办法：检查在定义该对象时，是否正确继承相关用户权限。
GAUSS-01764: "must have CREATEROLE privilege"
SQLSTATE: 42501
错误原因：如果不是初始用户，那至少是拥有基本的创建对象权限。
解决办法：检查持有该对象数据的用户权限，并核对对象的有效性。
GAUSS-01765: "unrecognized object type: %d"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-01766: "cache lookup failed for cache %d oid %u"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-01767: "unrecognized class id: %u"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-01768: "temporary tables cannot specify a schema name"
SQLSTATE: 42P16
错误原因：当前的临时表并不在创建临时表所创建的临时表空间中，即临时表所属的是其他空间，因此错误。
解决办法：检查创建临时表时临时表空间是否被正确创建，并查看对应的临时表空间的OID。
GAUSS-01769: "could not obtain lock on relation '%s.%s'"
SQLSTATE: 55P03
错误原因：无法请求到锁，因此报错。
解决办法：检查在该表上是否存在冲突锁或锁被分配完。
GAUSS-01770: "no schema has been selected to create in"
SQLSTATE: 3F000
错误原因：在创建表时没有指定相应的空间。
解决办法：创建某个schema或者进入某个已经创建好的schema，然后再次创建该表。
