
# GAUSS-01351 -- GAUSS-01360 错误码
GAUSS-01351: "cache lookup failed for text search template %u"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-01352: "text search template '%s' does not accept options"
SQLSTATE: 42601
错误原因：CREATE TEXT SEARCH DICTIONARY/ALTER TEXT SEARCH DICTIONARY，没有指定INIT方法，但是指定了options。
解决办法：CREATE TEXT SEARCH DICTIONARY/ALTER TEXT SEARCH DICTIONARY，要么在指定INIT时，才指定options选项，要么不要指定任何options。
GAUSS-01353: "text search template is required"
SQLSTATE: 42P17
错误原因：CREATE TEXT SEARCH DICTIONARY，没有提供template。
解决办法：CREATE TEXT SEARCH DICTIONARY，需要提供template。
GAUSS-01354: "cache lookup failed for text search dictionary %u"
SQLSTATE: XX000
错误原因：在系统表中未找到对应ID的全文检索词典。
解决办法：请检查是否有会话并发对该词典执行了drop操作。
GAUSS-01355: "text search dictionary '%s' already exists"
SQLSTATE: 42710
错误原因：ALTER TEXT SEARCH DICTIONARY name RENAME TO new_name，提供的新名字与旧名字冲突。
解决办法：ALTER TEXT SEARCH DICTIONARY name RENAME TO new_name，提供的新名字须不与旧名字冲突。
GAUSS-01356: "unrecognized attribute for text search template: %d"
SQLSTATE: XX000
错误原因：创建全文检索模板时，获取系统表pg_ts_template中指定列错误。
解决办法：系统表pg_ts_template属性信息错误，系统产生异常或由人为修改系统表属性导致，请联系技术支持工程师提供技术支持。
GAUSS-01357: "must be system admin to create text search templates"
SQLSTATE: 42501
错误原因：CREATE TEXT SEARCH TEMPLATE时，使用了非管理员账户。
解决办法：CREATE TEXT SEARCH TEMPLATE，需要使用系统管理员账户。
GAUSS-01358: "text search template parameter '%s' not recognized"
SQLSTATE: 42601
错误原因：CREATE TEXT SEARCH TEMPLATE，提供了不识别的模板参数。
解决办法：CREATE TEXT SEARCH TEMPLATE，不要提供init/lexize名称之外的模板参数。
GAUSS-01359: "text search template lexize method is required"
SQLSTATE: 42P17
错误原因：CREATE TEXT SEARCH TEMPLATE，没有提供合法的lexize方法。
解决办法：CREATE TEXT SEARCH TEMPLATE，需要提供合法的lexize方法。
GAUSS-01360: "must be system admin to rename text search templates"
SQLSTATE: 42501
错误原因：执行ALTER TEXT SEARCH TEMPLATE name RENAME TO new_name命令时，使用的账户不是系统管理员账户。
解决办法：执行ALTER TEXT SEARCH TEMPLATE name RENAME TO new_name命令时，必须使用管理员账户。
