
# GAUSS-01101 -- GAUSS-01110 错误码
GAUSS-01101: "%s requires an integer value"
SQLSTATE: 42601
错误原因：需要一个integer类型的参数，但语句中给的参数不是。
解决办法：检查SQL语句，给出正确的参数。
GAUSS-01102: "invalid argument for %s: '%s'"
SQLSTATE: 42601
错误原因：参数不合法。
解决办法：检查SQL语句，给出正确的参数。
GAUSS-01103: "table is not partitioned"
SQLSTATE: 0A000
错误原因：要cluster表分区，但此表不是分区表。
解决办法：检查表名，对普通表不能cluster分区。
GAUSS-01104: "cannot cluster temporary tables of other sessions"
SQLSTATE: 0A000
错误原因：不能cluster其他session创建的临时表。
解决办法：检查要cluster的表，不能CLUSTER其他session创建的临时表。
GAUSS-01105: "there is no previously clustered index for table '%s'"
SQLSTATE: 42704
错误原因：没有指定索引名称，此表之前也未执行过cluster，因此无法确定以哪个索引来执行cluster。
解决办法：如果不指定cluster的索引名称，就必须保证此表之前执行过cluster，系统使用上次cluster的索引。否则，需要指明要执行cluster的索引名称。
GAUSS-01106: "cannot cluster a shared catalog"
SQLSTATE: 0A000
错误原因：不能对一个多数据库间共享的系统表做cluster操作。
解决办法：请勿对共享的系统表执行cluster操作。
GAUSS-01107: "cannot vacuum temporary tables of other sessions"
SQLSTATE: 0A000
错误原因：不能VACUUM其他session创建的临时表。
解决办法：检查要VACUUM的表，不能VACUUM其他session创建的临时表。
GAUSS-01108: "'%s' is not an index for table '%s'"
SQLSTATE: 42809
错误原因：此索引不是这个表的索引，因此不能做cluster。
解决办法：检查SQL语句中索引和对应的表是否匹配。
GAUSS-01109: "cannot cluster on index '%s' because access method does not support clustering"
SQLSTATE: 0A000
错误原因：不能对此索引做cluster，此索引类型不支持cluster。
解决办法：请勿对此类型的索引做cluster，此索引类型不支持cluster。
GAUSS-01110: "cannot cluster on partial index '%s'"
SQLSTATE: 0A000
错误原因：不能对部分索引(partial index)执行cluster。
解决办法：请勿对部分索引(partial index)执行cluster。
