
# GAUSS-00581 -- GAUSS-00590 错误码
GAUSS-00581: "role name '%s' is reserved"
SQLSTATE: 42939
错误原因：用户名是保留关键字。
解决办法：用户名不能是public或none。
GAUSS-00582: "role '%s' already exists"
SQLSTATE: 42710
错误原因：创建的用户已存在。
解决办法：使用新的用户名。
GAUSS-00583: "Failed to Generate the random number"
SQLSTATE: XX000
错误原因：生成随机数失败。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-00584: "The password does not satisfy the complexity requirement"
SQLSTATE: XX000
错误原因：密码不符合复杂性要求。
解决办法："请参照密码规则进行修改：1. 不能和用户名相同。2. 至少包含大写字母（A-Z），小写字母（a-z），数字（0-9），非字母数字字符（\~!@#$%\^\&\*()-_=+\\\|\[{}\];:,\<.\>/?）四类字符中的三类字符，使用范围外的字符会收到告警，但依然允许修改。3. 密码默认不少于8个字符。
GAUSS-00585: "password md5 encryption failed"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-00586: "password sha256 encryption failed"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-00587: "Password_encryption_type is not 0, 1, 2"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
GAUSS-00588: "The password could not be NULL."
SQLSTATE: XX000
错误原因：密码为空。
解决办法：密码不允许为空。
GAUSS-00589: "unacceptable user name: fail to create same name schema for user '%s'"
SQLSTATE: 42939
错误原因：用户名非法，创建同名的schema失败。
解决办法：用户名不能以'pg_'开头，'pg_'开头主要用作系统模式。
GAUSS-00590: "the relation pg_user_status is invalid"
SQLSTATE: XX000
错误原因：系统内部错误。
解决办法：请联系技术支持工程师提供技术支持。
