Help Center> > SDK Reference > Android > Related Resources >SDK Download Links

SDK Download Links

Download Address

API Documentation

Compatibility

  • Recommended Android system versions: Android 4.5, 5.0, 5.1, 6.0, 7.0, 8.0, and 8.1 (HTTP/HTTPS)
  • Namespace: Compatible with earlier versions (2.1.x). All external APIs are contained in the com.obs.services, com.obs.services.model, and com.obs.services.exception packages.
  • API functions: Compatible with earlier versions (2.1.x).
    NOTE:

    If Android 4.4 or an earlier version is used, configure HTTP to access OBS.

ProGuard

#okhttp
-dontwarn okhttp3.**
-keep class okhttp3.**{*;}

#okio
-dontwarn okio.**
-keep class okio.**{*;}

#sdk
-keep class com.obs.services.** {*;}
-keep class com.obs.log.** {*;}

#java-xmlbuilder
-keep class com.jamesmurty.utils.**{*;}