Why Permissions Granted to a User Do Not Take Effect?
Symptom
Permissions that you grant to an IAM user have not taken effect.
Troubleshooting
- Incorrect permissions have been granted to the user group to which the user belongs.
Check and modify the permissions of the user group to which the user belongs by referring to Modifying User Group Permissions. For details about permissions, see System Permissions.
- Some permissions granted to the user deny the actions corresponding to the relevant operation.
Create a custom policy that allows these actions. For details, see Creating a Custom Policy.
- The IAM user has not been added to the group to which the administrator has assigned permissions.
Add the user to the group that has been granted the permissions. For details, see Adding Users to a User Group.
- The user is not assigned permissions for a regional service in the relevant region.
Assign permissions for the relevant region to the group to which the user belongs. If you have assigned the user only permissions for a default region-specific project, the user does not have permissions for the subprojects. In this case, assign permissions for the required subproject. For details, see Assigning Permissions to a User Group
- The IAM user has not switched to the region where the user has been authorized to use cloud resources.
Remind the user to switch to the region where the user is authorized to use cloud resources. For details, see Switching Regions.
- If the administrator has granted OBS permissions to the user, the permissions will take effect 15 to 30 minutes after the authorization.
- Your account is in arrears and you cannot use any resources.
Go to the Billing Center, view the bills, and top up your account. For details, see Topping Up an Account.
- The browser cache has not been cleared for a long time.
- The service (such as DevCloud and OBS) provides separate permissions control.
Grant the user permissions by referring to the service documentation. For example, Introduction to OBS Permission Control.
Related FAQ
Symptom: You have granted an IAM user only required permissions but the user has more permissions.
Possible causes:
- The required permissions you granted to the IAM user have dependency permissions, which are automatically assigned so that the required permissions can take effect for the user.
- You have granted other permissions to the IAM user in Enterprise Project Management. If you manage projects and users using IAM, cancel the permissions configured there. For details, see Removing Users from an Enterprise Project.
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