Help Center> Cloud Stream Service> FAQ> Job Related FAQs> What Should I Do If My CS Job Fails to Be Submitted Due to Connection Timeout?

What Should I Do If My CS Job Fails to Be Submitted Due to Connection Timeout?

Cause:

The network connection between the exclusive cluster where your CS job runs and the target address has been lost.

Solution:

Set up a VPC peering connection to ensure network connectivity between the exclusive cluster where your CS job runs and the target address.

For details about how to set up the VPC peering connection, see VPC Peering Connection in Cloud Stream Service User Guide.

After a VPC peering connection is created, test the address connectivity by referring to How Do I Confirm that My Exclusive Cluster Is Connected to a Specified Address?.

If the network is still disconnected, check related configurations by referring to What Can I Do If VPCs in a VPC Peering Connection Cannot Communicate with Each Other?.

CS jobs must run on exclusive clusters in any of the following scenarios:

  • CS outputs the job result to RDS.
  • CS outputs the job result to DWS in JDBC mode.
  • CS outputs the job result to the CSS cluster.
  • CS outputs the job result to the DCS Redis instance.
  • The source stream ingests data from Kafka as input data for CS jobs.
  • CS outputs the job result to Kafka.
  • CS outputs the job result to MRS HBase.

Before running a job in any of the preceding scenarios, ensure that a VPC peering connection has been established between the CS exclusive cluster where the job resides and the address to be connected.