Why Is the Error "Will not attempt to authenticate using SASL (unknown error)" Reported When Connecting to HBase?
Symptom
HBase fails to be connected to when accessing CloudTable and the following error information is displayed:
Opening socket connection to server 192.168.0.107/192.168.0.107:2181. Will not attempt to authenticate using SASL (unknown error)
Possible Cause
The possible cause is as follows:
- Network access failure
The link of CloudTable is an internal network address rather than a public network address. Therefore, CloudTable cannot be directly accessed from the public network. You can ping the ZooKeeper link of CloudTable on a client host. If it cannot be pinged, the network connection is abnormal.
Solution
You can use either of the following methods to prepare a client operating environment:
- Preparing an ECS
If you use an ECS as a client host, you need to prepare the ECS that is in the same region, VPC, subnet, and security group as the CloudTable cluster for accessing CloudTable. In addition, you need to correctly configure a DNS server address for the ECS.
- Preparing a Local Windows Environment (VPN Connection Mode)
If you access CloudTable in the local Windows environment, you need to apply for a Linux ECS as a VPN server. The Linux ECS and the CloudTable cluster must be in the same region, AZ, VPC, subnet, and security group. Then, you can use VPN to access CloudTable through the Linux ECS in the local Windows environment.
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