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What Should I Do If a Cluster Fails to Be Deleted?

To delete a cluster, CCE connects to the kube-apiserver of the cluster to query information about its resources, such as the elastic network interfaces (ENIs) or sub ENIs connected to a CCE Turbo cluster. If the cluster is in the unavailable, frozen, or hibernated state, it may fail to be deleted due to a resource query failure.

Symptom

Failed to delete a cluster.

Possible Cause

In this example, the ENI cannot be deleted because kube-apiserver of the cluster fails to query the ENI or sub ENI of the cluster. The security group created by CCE for the ENI or sub ENI reports the error code 409. As a result, the cluster fails to be deleted.

Procedure

  1. Copy the resource ID f5b0282b-6306-4a4b-a64d-bd32e26c3846, go to the Security Groups page of the VPC console, and filter security groups by ID.

  2. Click the security group to view its details, and click the Associated Instances tab.

    The cause of the residual security group is that the security group is associated with the ENI and sub ENI. Click the Others tab to view the two ENIs. Delete the residual ENI, and the supplementary ENI will be automatically deleted.

  3. Choose Network Interfaces in the console navigation pane to delete the ENIs queried in the previous step.

    You can filter the ENIs to be deleted by ID or name (cluster ID). In this example, filter the ENIs by name through the cluster ID ac41231a-c5a9-11eb-a0cf-0255ac100440.

  4. After the clearing, go to the Security Groups page to check that Cluster name-cce-eni-xxx does not have associated instances. Then, you can delete the cluster on the CCE console.