Help Center> Cloud Container Engine> FAQ> Workload> Others> Why Does the Client Fail to Receive Subscription Information After an Application Is Deployed on CCE?

Why Does the Client Fail to Receive Subscription Information After an Application Is Deployed on CCE?

A subscription server (redis) is deployed on CCE. After receiving a subscription request from a client, the subscription server pushes information to the client periodically.

Symptom

The first sub/pub interaction is successful. However, after a 10-minute period of no data transfer between the server and the client, the client cannot receive any information.

Possible Cause

When the client establishes a communication link with the server for the first time to send a subscription request, the client actively allows communication with the server. However, the communication link expires in 10 minutes because the cluster's security group rules have a 10-minute aging time. There are no security group rules for the client. As a result, the server cannot initiate communication again and subsequent sub/pub is abnormal.

Solution

To add security group rules for the client, perform the following steps:

  1. Log in to the ECS console. In the navigation pane, choose Access Control > Security Groups.
  2. Click Create Security Group. Configure security group parameters and click OK.

    Figure 1 Creating a security group

  3. Add an inbound rule.

    Figure 2 Adding an inbound rule

  4. Add an outbound rule.

    Figure 3 Adding an outbound rule