
# 如何排查ELB返回至客户端的异常请求头？
在异常返回码的基础上，ELB会将典型的异常情况通过"x-router-code" header头通知客户端，常见的有40000，40001，50000， 50001，您可以参考下表排查异常header值的可能原因：
表1ELB返回至客户端的异常请求头 
| header值 | 含义                     | 可能原因                                                                                                                                                                                                                       |
|:---|:---|:---|
| 40000   | 默认后端服务器组没有配置后端后端服务器    | - 客户端请求没有命中任何转发策略。  - 后端服务器组没有配置后端服务器。                |
| 40001   | 转发策略对应的后端服务器组没有配置后端服务器 | - 客户端请求命中了错误的转发策略。  - 转发策略对应的后端服务器组没有配置后端服务器。                |
| 50000   | ELB的后端服务器全都不可用         | - 健康检查配置异常，导致ELB认为后端服务器异常不可用。  - 后端服务器自身异常不可用，需自行排查后端服务器。   |
| 50001   | 配置正在加载中                | 配置尚未加载完毕，请等待配置加载完成，稍后重试。                                                                                                                                                                                                   |
   
