
# 为什么使用密钥文件无法正常登录Linux弹性云服务器？
#### 问题描述
用户使用创建弹性云服务器时使用的密钥文件登录Linux弹性云服务器时，登录失败。
#### 可能原因
根据Linux弹性云服务器使用的镜像不同，可能会存在如下原因：
- 原因一：Linux弹性云服务器的镜像为用户自己制作的私有镜像，且在创建该私有镜像时用户未安装Cloud-init工具。
- 原因二：Linux弹性云服务器的镜像安装了Cloud-init工具，但是在创建弹性云服务器时，获取密钥失败。
 
#### 处理方法
- 针对原因一： 创建私有镜像时不安装Cloud-init工具，将无法对弹性云服务器进行自定义配置，此时，用户只能使用镜像原有密码或密钥登录弹性云服务器。
  其中，镜像原有密码或密钥指创建私有镜像时，用户自己设置的操作系统密码或密钥。
  如果忘记镜像原有密码，或镜像原有密钥丢失，可以通过弹性云服务器页面提供的"重置密码"功能，自助完成弹性云服务器的密码重置。
  Cloud-init的更多介绍，请参见[（可选）安装和配置Cloud-Init工具](https://support.huaweicloud.com/usermanual-ims/zh-cn_topic_0030730603.html)。
  
- 针对原因二：
  1. 勾选待获取密钥的弹性云服务器，单击"重启"，重新启动弹性云服务器。
  
  2. 重启成功后，再次使用密钥文件登录弹性云服务器，确认是否能够正常登录。
     - 是，结束。
     
     - 否，请联系客服寻求技术支持。
      
   
 
